summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-romulus
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-05-14 17:34:18 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-05-21 17:23:35 +0300
commit146f7af0ee6a560eb9289d61e8be65f5d3413d4f (patch)
treeedb6107204d2434554a383512165884bb086dada /meta-ibm/meta-romulus
parentdd12ede1c7012fe519dca9a03dfeddcf55cb676f (diff)
downloadopenbmc-146f7af0ee6a560eb9289d61e8be65f5d3413d4f.tar.xz
meta-ibm: romulus: fans: switch to non-native
meta-phosphor recently enabled target class config recipes. Those are preferable to native class config recipes because native recipes cannot be overridden based on MACHINE, so switch to target class config recipes. Switching to target class recipes consists of temporarily setting PHOSPHOR_FAN_CONFIG_USE_NATIVE_SYSROOT to 0, overriding the phosphor distro default of 1. After all OpenBMC BSP layers have moved to target class config recipes PHOSPHOR_FAN_CONFIG_USE_NATIVE_SYSROOT can be removed from meta-phosphor and any BSP layers. Any references to -native recipes are replaced with their target class counterparts. Any -native bbappends are re-worked to apply to their target class counterparts. Finally, use BPN instead of PN when setting FILESEXTRAPATHS, to avoid unfortunate directory hierarchies if these bbappends are copy/pasted and then used to bbappend a native recipe. Since this patch moves to target class recipes, this is a noop; however, this avoids unfortunate directory hierarchies with native bbappends such as: meta-base/recipes-foo/bar/baz-native.bb meta-base/recipes-foo/bar/baz/a-file meta-append/recipes-foo/bar/baz-native.bbappend meta-append/recipes-foo/bar/baz-native/b-file Using "${THISDIR}/${BPN}:" enables a more sensible hierarchy: meta-base/recipes-foo/bar/baz-native.bb meta-base/recipes-foo/bar/baz/a-file meta-append/recipes-foo/bar/baz-native.bbappend meta-append/recipes-foo/bar/baz/b-file This behavior occurs because By default FILESPATH is set in base.bbclass (in OE-Core) to look for files in ${BP}, ${BPN} and files (and a number of subdirectories of those based on ${FILESOVERRIDES}). (From meta-ibm rev: 589ee00a5ec7bc97c7d5c079cf66b3dbd3ac2b4f) Change-Id: I1a593373f1b4bc82c554a9330cdd75f04f21d1d8 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm/meta-romulus')
-rw-r--r--meta-ibm/meta-romulus/conf/machine/romulus.conf1
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-events-config-native.bbappend1
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-events-config.bbappend1
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-events-config/events.yaml (renamed from meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-events-config-native/events.yaml)0
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-fan-config-native.bbappend1
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-fan-config.bbappend1
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-fan-config/fans.yaml (renamed from meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-fan-config-native/fans.yaml)0
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native.bbappend1
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config.bbappend1
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config/zone_conditions.yaml (renamed from meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native/zone_conditions.yaml)0
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config-native.bbappend2
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config.bbappend2
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config/zones.yaml (renamed from meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config-native/zones.yaml)0
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-monitor-config-native.bbappend1
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend1
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-monitor-config/monitor.yaml (renamed from meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-monitor-config-native/monitor.yaml)0
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-presence-config-native.bbappend1
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend1
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-presence-config/config.yaml (renamed from meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-presence-config-native/config.yaml)0
-rw-r--r--meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend2
20 files changed, 9 insertions, 8 deletions
diff --git a/meta-ibm/meta-romulus/conf/machine/romulus.conf b/meta-ibm/meta-romulus/conf/machine/romulus.conf
index 4b580a2206..2c3c62158f 100644
--- a/meta-ibm/meta-romulus/conf/machine/romulus.conf
+++ b/meta-ibm/meta-romulus/conf/machine/romulus.conf
@@ -1,6 +1,7 @@
KMACHINE = "aspeed"
KERNEL_DEVICETREE = "${KMACHINE}-bmc-opp-${MACHINE}.dtb"
+PHOSPHOR_FAN_CONFIG_USE_NATIVE_SYSROOT = "0"
UBOOT_MACHINE = "ast_g5_ncsi_config"
PREFERRED_PROVIDER_virtual/p9-vcs-workaround = ''
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-events-config-native.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-events-config-native.bbappend
deleted file mode 100644
index 4db6f3a6d7..0000000000
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-events-config-native.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${PN}:"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-events-config.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-events-config.bbappend
new file mode 100644
index 0000000000..781af4fcf9
--- /dev/null
+++ b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-events-config.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${BPN}:"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-events-config-native/events.yaml b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-events-config/events.yaml
index ddf1556d26..ddf1556d26 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-events-config-native/events.yaml
+++ b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-events-config/events.yaml
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-fan-config-native.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-fan-config-native.bbappend
deleted file mode 100644
index 4db6f3a6d7..0000000000
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-fan-config-native.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${PN}:"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-fan-config.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-fan-config.bbappend
new file mode 100644
index 0000000000..781af4fcf9
--- /dev/null
+++ b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-fan-config.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${BPN}:"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-fan-config-native/fans.yaml b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-fan-config/fans.yaml
index f910e6253d..f910e6253d 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-fan-config-native/fans.yaml
+++ b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-fan-config/fans.yaml
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native.bbappend
deleted file mode 100644
index 4db6f3a6d7..0000000000
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${PN}:"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config.bbappend
new file mode 100644
index 0000000000..781af4fcf9
--- /dev/null
+++ b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${BPN}:"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native/zone_conditions.yaml b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config/zone_conditions.yaml
index 7dc99b6a20..7dc99b6a20 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config-native/zone_conditions.yaml
+++ b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-conditions-config/zone_conditions.yaml
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config-native.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config-native.bbappend
deleted file mode 100644
index 7be43dde09..0000000000
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config-native.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${PN}:"
-
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config.bbappend
new file mode 100644
index 0000000000..83b54c4185
--- /dev/null
+++ b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${BPN}:"
+
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config-native/zones.yaml b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config/zones.yaml
index 91df5c25d3..91df5c25d3 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config-native/zones.yaml
+++ b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-control-zone-config/zones.yaml
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-monitor-config-native.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-monitor-config-native.bbappend
deleted file mode 100644
index 4db6f3a6d7..0000000000
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-monitor-config-native.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${PN}:"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
new file mode 100644
index 0000000000..781af4fcf9
--- /dev/null
+++ b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${BPN}:"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-monitor-config-native/monitor.yaml b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-monitor-config/monitor.yaml
index 445a111a8b..445a111a8b 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-monitor-config-native/monitor.yaml
+++ b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-monitor-config/monitor.yaml
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-presence-config-native.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-presence-config-native.bbappend
deleted file mode 100644
index 4db6f3a6d7..0000000000
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-presence-config-native.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${PN}:"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
new file mode 100644
index 0000000000..781af4fcf9
--- /dev/null
+++ b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${BPN}:"
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-presence-config-native/config.yaml b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-presence-config/config.yaml
index 5acb91fc7b..5acb91fc7b 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-presence-config-native/config.yaml
+++ b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan-presence-config/config.yaml
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend
index 5c930a04de..af5e1e6296 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend
+++ b/meta-ibm/meta-romulus/recipes-phosphor/fans/phosphor-fan_%.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend_romulus := "${THISDIR}/${BPN}:"
# Package configuration
FAN_PACKAGES += " \