summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-witherspoon/recipes-phosphor/gpio
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-07-18 00:35:55 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-07-24 04:18:54 +0300
commita29c2d5e6187adb2c309d049226085eb1283b555 (patch)
tree0fa19fd4aa4a95779e503e235109b769a013138d /meta-ibm/meta-witherspoon/recipes-phosphor/gpio
parentead9ee683e5829b00afae3032df6d4e505f492b6 (diff)
downloadopenbmc-a29c2d5e6187adb2c309d049226085eb1283b555.tar.xz
meta-ibm: use ibm-ac-server MACHINEOVERRIDE
Use an override in bbappends in meta-witherspoon as described and recommended in the "following best practices when creating layers" section of the the Yocto development tasks manual. ibm-ac-server represents common machine configuration shared by all of IBMs "Accelerated Compute" class of servers. Apply it wherever any variables are un-bounded by any override. This enables more flexible use of meta-witherspoon in build configurations, and easy addition of machines to the layer. (From meta-ibm rev: bb0e1d0699a4b9905c053c94af7d882cd71779fc) Change-Id: I82f7338b0d7a64b5e7a67e19bcdff07f48a332d4 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm/meta-witherspoon/recipes-phosphor/gpio')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
index f5a358200b..032056c264 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/gpio/phosphor-gpio-monitor_%.bbappend
@@ -5,8 +5,8 @@ INSTFMT_POWERSUPPLY = "phosphor-gpio-presence@{0}.service"
POWERSUPPLY_TGT = "multi-user.target"
FMT_POWERSUPPLY = "../${TMPL_POWERSUPPLY}:${POWERSUPPLY_TGT}.requires/${INSTFMT_POWERSUPPLY}"
-SYSTEMD_LINK_${PN}-presence += "${@compose_list(d, 'FMT_POWERSUPPLY', 'OBMC_POWER_SUPPLY_INSTANCES')}"
+SYSTEMD_LINK_${PN}-presence_append_ibm-ac-server = " ${@compose_list(d, 'FMT_POWERSUPPLY', 'OBMC_POWER_SUPPLY_INSTANCES')}"
POWERSUPPLY_ENV_FMT = "obmc/gpio/phosphor-power-supply-{0}.conf"
-SYSTEMD_ENVIRONMENT_FILE_${PN}-presence += "${@compose_list(d, 'POWERSUPPLY_ENV_FMT', 'OBMC_POWER_SUPPLY_INSTANCES')}"
+SYSTEMD_ENVIRONMENT_FILE_${PN}-presence_append_ibm-ac-server = " ${@compose_list(d, 'POWERSUPPLY_ENV_FMT', 'OBMC_POWER_SUPPLY_INSTANCES')}"