summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-witherspoon/recipes-phosphor
diff options
context:
space:
mode:
authorLei YU <mine260309@gmail.com>2019-10-24 08:01:46 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-29 21:53:33 +0300
commit9a1d1a08e7f7617fa6dd9ae62fdcdd781383ed0c (patch)
treebc3eb2cd7df8a8667c03ee8591cc98f7645c37bc /meta-ibm/meta-witherspoon/recipes-phosphor
parenteb93df84e25a1936c50dfc381ecb8cfed496d832 (diff)
downloadopenbmc-9a1d1a08e7f7617fa6dd9ae62fdcdd781383ed0c.tar.xz
meta-witherspoon: Add psu.json for phosphor-power
The service psu-monitor in phosphor-power now requires psu.json to run. Otherwise it fails due to unable to open and parse the JSON file. Install psu.json for Witherspoon so it works OK. Tested: On Witherspoon, the psu-monitor services are started correctly, and the PSU model, serial, etc are correct in inventory. (From meta-ibm rev: 19034168062473250be4e8faafbd85b0d029c0d9) Change-Id: Ia647f3d540e3ed685ab134ae42aef67e32fc5e81 Signed-off-by: Lei YU <mine260309@gmail.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm/meta-witherspoon/recipes-phosphor')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/psu.json25
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb6
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/psu.json b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/psu.json
new file mode 100644
index 0000000000..2dcefab2b3
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis/psu.json
@@ -0,0 +1,25 @@
+{
+ "inventoryPMBusAccessType": "HwmonDeviceDebug",
+ "fruConfigs": [
+ {
+ "propertyName": "PartNumber",
+ "fileName": "part_number",
+ "interface": "xyz.openbmc_project.Inventory.Decorator.Asset"
+ },
+ {
+ "propertyName": "SerialNumber",
+ "fileName": "serial_number",
+ "interface": "xyz.openbmc_project.Inventory.Decorator.Asset"
+ },
+ {
+ "propertyName": "Model",
+ "fileName": "ccin",
+ "interface": "xyz.openbmc_project.Inventory.Decorator.Asset"
+ },
+ {
+ "propertyName": "Version",
+ "fileName": "fw_version",
+ "interface": "xyz.openbmc_project.Software.Version"
+ }
+ ]
+}
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb
index 49fe344dc0..2625bfc387 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb
@@ -11,6 +11,7 @@ inherit pythonnative
require ${PN}.inc
S = "${WORKDIR}/git"
+SRC_URI += "file://psu.json"
DEPENDS += " \
phosphor-logging \
@@ -24,6 +25,11 @@ DEPENDS += " \
EXTRA_OEMESON += "-Ducd90160-yaml=${STAGING_DIR_HOST}${datadir}/power-sequencer/ucd90160.yaml"
+do_install_append(){
+ install -D ${WORKDIR}/psu.json ${D}${datadir}/phosphor-power/psu.json
+}
+FILES_${PN} += "${datadir}/phosphor-power/psu.json"
+
CHASSIS_ON_TGT = "obmc-chassis-poweron@0.target"
SEQ_MONITOR_SVC = "pseq-monitor.service"
SEQ_MONITOR_FMT = "../${SEQ_MONITOR_SVC}:${CHASSIS_ON_TGT}.wants/${SEQ_MONITOR_SVC}"