summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-witherspoon
diff options
context:
space:
mode:
authorAndrew Jeffery <andrew@aj.id.au>2020-02-17 08:04:34 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-14 22:26:06 +0300
commit1688b154fead9646a2e023363d8ebf84fcaf9743 (patch)
treeac3ee8435ebdc8ced25d829522bfcc04a342baef /meta-ibm/meta-witherspoon
parent274f96aa19d8a5b241c4676f223d4398e5fb3918 (diff)
downloadopenbmc-1688b154fead9646a2e023363d8ebf84fcaf9743.tar.xz
meta-witherspoon: rainier: Enable concurrent console servers
The Rainier design makes use of both virtual UARTs provided by the AST2600. Expose them both to the network via obmc-console. (From meta-ibm rev: 9c0807e8741e95b33cad604d62138650ac2143ea) Change-Id: I8659fad4809a859b857bfc91a14defcfbc3b030d Signed-off-by: Andrew Jeffery <andrew@aj.id.au> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-ibm/meta-witherspoon')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/rainier/client.2201.conf1
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/rainier/server.ttyVUART0.conf5
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/rainier/server.ttyVUART1.conf3
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console_%.bbappend42
4 files changed, 51 insertions, 0 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/rainier/client.2201.conf b/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/rainier/client.2201.conf
new file mode 100644
index 0000000000..7264e82784
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/rainier/client.2201.conf
@@ -0,0 +1 @@
+socket-id = guests
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/rainier/server.ttyVUART0.conf b/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/rainier/server.ttyVUART0.conf
new file mode 100644
index 0000000000..638ae7e5d9
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/rainier/server.ttyVUART0.conf
@@ -0,0 +1,5 @@
+lpc-address = 0x3f8
+sirq = 4
+local-tty = ttyS0
+local-tty-baud = 115200
+logsize = 256k
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/rainier/server.ttyVUART1.conf b/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/rainier/server.ttyVUART1.conf
new file mode 100644
index 0000000000..e98587f151
--- /dev/null
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console/rainier/server.ttyVUART1.conf
@@ -0,0 +1,3 @@
+lpc-address = 0x2f8
+sirq = 3
+socket-id = guests
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console_%.bbappend
index b121be7af2..75ec2e0ba9 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/console/obmc-console_%.bbappend
@@ -2,3 +2,45 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI_remove = "file://${BPN}.conf"
SRC_URI += "file://server.ttyVUART0.conf"
+
+install_concurrent_console_config() {
+ # Install configuration for the servers and clients. Keep commandline
+ # compatibility with previous configurations by defaulting to not
+ # specifying a socket-id for VUART0/2200
+ install -m 0755 -d ${D}${sysconfdir}/${BPN}
+
+ # Remove the default client configuration as we don't to define a
+ # socket-id for the 2200 console
+ rm -f ${D}${sysconfdir}/${BPN}/client.2200.conf
+
+ # However, now link to /dev/null as a way of not specifying a
+ # socket-id while having a configuration file present. We need to
+ # provide a configuration path to meet the requirements of the packaged
+ # unit file.
+ ln -sr ${D}/dev/null ${D}${sysconfdir}/${BPN}/client.2200.conf
+
+ # We need to populate socket-id for remaining consoles
+ install -m 0644 ${WORKDIR}/client.2201.conf ${D}${sysconfdir}/${BPN}/
+
+ # Install configuration for remaining servers - the base recipe
+ # installs the configuration for the first.
+ install -m 0644 ${WORKDIR}/server.ttyVUART1.conf ${D}${sysconfdir}/${BPN}/
+}
+
+SRC_URI_append_rainier = " file://client.2201.conf"
+SRC_URI_append_rainier = " file://server.ttyVUART1.conf"
+
+REGISTERED_SERVICES_${PN}_append_rainier = " obmc_console_guests:tcp:2201:"
+
+SYSTEMD_SERVICE_${PN}_append_rainier = " obmc-console-ssh@2200.service \
+ obmc-console-ssh@2201.service \
+ "
+SYSTEMD_SERVICE_${PN}_remove_rainier = "obmc-console-ssh.socket"
+
+FILES_${PN}_remove_rainier = "/lib/systemd/system/obmc-console-ssh@.service.d/use-socket.conf"
+
+EXTRA_OECONF_append_rainier = " --enable-concurrent-servers"
+
+do_install_append_rainier() {
+ install_concurrent_console_config
+}