summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-witherspoon
diff options
context:
space:
mode:
authorSantosh Puranik <santosh.puranik@in.ibm.com>2020-03-20 18:41:30 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-03-26 17:52:12 +0300
commit7115655a04bde87085438422448686bea8cd0fcd (patch)
tree535fc37719c8230605cf2c62e7aba5e6fef776f0 /meta-ibm/meta-witherspoon
parent67f272f241a92ecbf5f85c38bfa165960ecdef93 (diff)
downloadopenbmc-7115655a04bde87085438422448686bea8cd0fcd.tar.xz
Fix Inventory File For Tacoma
This commit fixes the inventory file used by openpower-vpd-parser on Tacoma. Changes include: * Fix the EEPROM path used to point to the right I2C bus. * Fix the FRUs and OBJECTs that the file contains. Tested: Made sure that the right inventory file makes it to the image. (From meta-ibm rev: f591790414025f25947b2327021e86d4d70709ab) Signed-off-by: Santosh Puranik <santosh.puranik@in.ibm.com> Change-Id: I20852c9cc2aa6875673925c7588b335dc2ee29d0 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-ibm/meta-witherspoon')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/vpd/openpower-fru-vpd_%.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/vpd/openpower-fru-vpd_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/vpd/openpower-fru-vpd_%.bbappend
index 3fc3d487eb..6c0cbeba97 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/vpd/openpower-fru-vpd_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/vpd/openpower-fru-vpd_%.bbappend
@@ -7,3 +7,11 @@ do_install_append_swift() {
DEST=${D}${inventory_envdir}
printf "\nEEPROM=/sys/devices/platform/ahb/ahb:apb/ahb:apb:bus@1e78a000/1e78a340.i2c-bus/i2c-8/8-0051/eeprom" >> ${DEST}/inventory
}
+
+do_install_append_witherspoon-tacoma() {
+ DEST=${D}${inventory_envdir}
+ printf "FRUS=BMC,ETHERNET" > ${DEST}/inventory
+ printf "\nPATHS=/system/chassis/motherboard/bmc,/system/chassis/motherboard/bmc/eth0" >> ${DEST}/inventory
+ printf "\nEEPROM=/sys/devices/platform/ahb/ahb:apb/ahb:apb:bus@1e78a000/1e78a600.i2c-bus/i2c-11/11-0051/eeprom" >> ${DEST}/inventory
+}
+