summaryrefslogtreecommitdiff
path: root/meta-ibm/meta-witherspoon
diff options
context:
space:
mode:
authorSantosh Puranik <santosh.puranik@in.ibm.com>2019-10-11 20:54:52 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-17 15:17:25 +0300
commit87d92e586e31844e6a3745b0c84f02f2a99809b4 (patch)
treed9df3e724d666a814ddd96761768dccc363d737c /meta-ibm/meta-witherspoon
parentf3b54df0bb4a9cd9148d2deaec2e3d927724a9ad (diff)
downloadopenbmc-87d92e586e31844e6a3745b0c84f02f2a99809b4.tar.xz
Extra argument to IPMI parsers
This commit adds an option to the invocation of IPMI MRW parsers within the IBM layer to allow them to parse an incomplete MRW. The extra option is only enabled for the Rainier machine. Tested: I updated rainier.conf to point to the in progress Rainier MRW and made sure that with the new option in the recipe, the IPMI parsers no longer complained about a broken MRW. (From meta-ibm rev: 7c056f4b459fa67dc911b40e14055b86dbf1ef46) Signed-off-by: Santosh Puranik <santosh.puranik@in.ibm.com> Change-Id: I4482a09c93ab727b7330946f61e52a8ec92753fc Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm/meta-witherspoon')
-rw-r--r--meta-ibm/meta-witherspoon/conf/machine/rainier.conf1
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb9
2 files changed, 6 insertions, 4 deletions
diff --git a/meta-ibm/meta-witherspoon/conf/machine/rainier.conf b/meta-ibm/meta-witherspoon/conf/machine/rainier.conf
index 03f2623ef1..628a45a222 100644
--- a/meta-ibm/meta-witherspoon/conf/machine/rainier.conf
+++ b/meta-ibm/meta-witherspoon/conf/machine/rainier.conf
@@ -21,3 +21,4 @@ PREFERRED_PROVIDER_virtual/phosphor-fan-presence-config_df-mrw = \
"phosphor-fan-presence-config"
FLASH_SIZE = "131072"
+SKIP_BROKEN_MRW = "1"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb
index 5371c3a096..5ec7d45656 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/configuration/acx22-yaml-config.bb
@@ -50,18 +50,19 @@ do_install() {
# generate extra-properties.yaml from the MRW for ipmi-fru-parser
$perlbin $scriptpath/gen_fru_properties.pl -m $mrw \
-c $op_configpath/ipmi-fru-properties-mrw.yaml \
- -o extra-properties.yaml
+ -o extra-properties.yaml ${EXTRA_MRW_SCRIPT_ARGS}
# generate fru-read.yaml from the MRW, for ipmid and ipmi-fru-parser
$perlbin $scriptpath/gen_ipmi_fru.pl -i $mrw \
-m $op_configpath/ipmi-hostboot-fru-mrw.yaml \
- -o fru-read-partial.yaml
+ -o fru-read-partial.yaml ${EXTRA_MRW_SCRIPT_ARGS}
cat fru-read-partial.yaml ${ACx22_IPMI_EXTRA_FRU_READ_YAMLS} \
> fru-read.yaml
# generate inventory-sensors.yaml from the MRW, for ipmid
$perlbin $scriptpath/gen_ipmi_sel.pl -i $mrw \
- -m acx22-ipmi-inventory-sensors.yaml -o inventory-sensors.yaml
+ -m acx22-ipmi-inventory-sensors.yaml -o inventory-sensors.yaml \
+ ${EXTRA_MRW_SCRIPT_ARGS}
# generate sensors.yaml from the MRW, for ipmid
cat acx22-ipmi-sensors-mrw.yaml \
@@ -69,7 +70,7 @@ do_install() {
$op_configpath/ipmi-occ-active-sensor-mrw.yaml \
> sensors-mrw.yaml
$perlbin $scriptpath/gen_ipmi_sensor.pl -i $mrw -m sensors-mrw.yaml \
- -o sensors-partial.yaml
+ -o sensors-partial.yaml ${EXTRA_MRW_SCRIPT_ARGS}
cat sensors-partial.yaml ${ACx22_IPMI_EXTRA_SENSOR_YAMLS} \
> sensors.yaml