summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor/telemetry
diff options
context:
space:
mode:
authorAli Ahmed <ama213000@gmail.com>2022-06-22 07:36:30 +0300
committerGunnar Mills <gmills@us.ibm.com>2022-08-15 21:42:17 +0300
commit0d4889e4413f0a70aaf0d8125bf2462bfa496dc3 (patch)
tree4f91de706bb3a384b629b55026a5378ab76eae6e /meta-ibm/recipes-phosphor/telemetry
parentb6b9ec4ddd3889f4dd7a089bc3e5ddcefa3f3f55 (diff)
downloadopenbmc-0d4889e4413f0a70aaf0d8125bf2462bfa496dc3.tar.xz
meta-ibm: Add telemetry bbappend
Adding telemetry bbappend to customize telemetry meson options for IBM. IBM has different needs than upstream for telemetry capacity in terms of numbers of sensors readings and rate of requests. bbappend file allows IBM to stay up to date with upstream Telemetry while maintain custom build options more suited to IBM's usecases. Increase meson option for total maximum Metrics/MetricProperties limit from 200 to 300. For IBM management agent use cases (HMC), the max number of Metrics needs to greater than 200. Also for IBM management agent use cases, telemetry reports need a higher append limit for metric readings. 32768 was determined as 1) a power of 2, 2) higher than HMC's current usage, 3) Ability to collect one hour of data for 250 sensors reading once every 30 seconds ==> a general guess as to maximum readings needed in one report. Testing for maximum metrics increase: - Monitored CPU usage of bmcweb for both rainier and everest systems. bmcweb usage spiked for around 2 seconds with 300 MetricProperty MRD. - MRD was periodic on 15 interval with 300 MetricProperties averaged over 30 seconds on everest system with 360 sensors. Max bmcweb usage was 9% for brief instant when MRD post call is made. Testing for appendLimit increase: - Set AppendLimit up to 11000 with 150 sensors on 400+ sensor system. - Monitored 'top' CPU usage for telemetry binary and bmcweb binary which never ran above 5%. AppendLimit generated new metric entries for the report. - Retrieve report did seem to take a little longer as report grew but not significantly. - Tested various other lower limits and sensors Signed-off-by: Ali Ahmed <ama213000@gmail.com> Signed-off-by: Gunnar Mills <gmills@us.ibm.com> Change-Id: I418c3e90c565770cd59b02c294754ff98df29a55
Diffstat (limited to 'meta-ibm/recipes-phosphor/telemetry')
-rw-r--r--meta-ibm/recipes-phosphor/telemetry/telemetry_%.bbappend4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/telemetry/telemetry_%.bbappend b/meta-ibm/recipes-phosphor/telemetry/telemetry_%.bbappend
new file mode 100644
index 0000000000..089963c424
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/telemetry/telemetry_%.bbappend
@@ -0,0 +1,4 @@
+EXTRA_OEMESON:append:p10bmc = " \
+ -Dmax-append-limit=300 \
+ -Dmax-reading-parameters=32768 \
+"