summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2023-06-30 23:46:00 +0300
committerAndrew Geissler <geissonator@yahoo.com>2023-07-18 17:28:06 +0300
commitb5c22690c606423fcf2a79cfd691f174f49b08ee (patch)
tree42a8ad6c0f3909dbd2857405eba97727da9f6685 /meta-ibm/recipes-phosphor
parentd8edd104e2ed89b51a5adebab05724960bd9dd55 (diff)
downloadopenbmc-b5c22690c606423fcf2a79cfd691f174f49b08ee.tar.xz
meta-ibm: only use openpower bbappend when including layer
There is a desire to add non-openpower systems to the meta-ibm layer. To do that, need to ensure the bbappend files that are appending to openpower recipes are only included if the machine being built includes the meta-openpower layer. Tested: - Confirmed a system not including meta-openpower builds ok with this - Confirmed p10bmc still uses the bbappend files Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I32a08e9f20a20152d51c77cdfca6bbc15b5e93d4
Diffstat (limited to 'meta-ibm/recipes-phosphor')
-rw-r--r--meta-ibm/recipes-phosphor/debug/openpower-debug-collector_%.bbappend1
-rw-r--r--meta-ibm/recipes-phosphor/flash/openpower-software-manager_%.bbappend1
-rw-r--r--meta-ibm/recipes-phosphor/host/op-proc-control_git.bbappend1
-rw-r--r--meta-ibm/recipes-phosphor/host/p9-host-start.bbappend3
-rw-r--r--meta-ibm/recipes-phosphor/ipmi/openpower-ipmi-oem_%.bbappend5
-rw-r--r--meta-ibm/recipes-phosphor/packagegroups/packagegroup-op-apps.bbappend1
-rw-r--r--meta-ibm/recipes-phosphor/vpd/openpower-fru-vpd_%.bbappend50
7 files changed, 0 insertions, 62 deletions
diff --git a/meta-ibm/recipes-phosphor/debug/openpower-debug-collector_%.bbappend b/meta-ibm/recipes-phosphor/debug/openpower-debug-collector_%.bbappend
deleted file mode 100644
index d20060c85e..0000000000
--- a/meta-ibm/recipes-phosphor/debug/openpower-debug-collector_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-EXTRA_OEMESON:append:p10bmc = " -Dhostboot-dump-collection=enabled "
diff --git a/meta-ibm/recipes-phosphor/flash/openpower-software-manager_%.bbappend b/meta-ibm/recipes-phosphor/flash/openpower-software-manager_%.bbappend
deleted file mode 100644
index 38b5e4749c..0000000000
--- a/meta-ibm/recipes-phosphor/flash/openpower-software-manager_%.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-PACKAGECONFIG:append:ibm-ac-server = " verify_pnor_signature" \ No newline at end of file
diff --git a/meta-ibm/recipes-phosphor/host/op-proc-control_git.bbappend b/meta-ibm/recipes-phosphor/host/op-proc-control_git.bbappend
deleted file mode 100644
index 47869c4f31..0000000000
--- a/meta-ibm/recipes-phosphor/host/op-proc-control_git.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-PACKAGECONFIG:append:p10bmc = " phal"
diff --git a/meta-ibm/recipes-phosphor/host/p9-host-start.bbappend b/meta-ibm/recipes-phosphor/host/p9-host-start.bbappend
deleted file mode 100644
index b2a9fd8225..0000000000
--- a/meta-ibm/recipes-phosphor/host/p9-host-start.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-RDEPENDS:${PN}:append:ibm-ac-server = " avsbus-control"
-RDEPENDS:${PN}:append:witherspoon = " vrm-control"
-RDEPENDS:${PN}:append:ibm-ac-server = " power-workarounds"
diff --git a/meta-ibm/recipes-phosphor/ipmi/openpower-ipmi-oem_%.bbappend b/meta-ibm/recipes-phosphor/ipmi/openpower-ipmi-oem_%.bbappend
deleted file mode 100644
index 8ce54e536e..0000000000
--- a/meta-ibm/recipes-phosphor/ipmi/openpower-ipmi-oem_%.bbappend
+++ /dev/null
@@ -1,5 +0,0 @@
-DEPENDS:append:ibm-ac-server = " acx22-yaml-config"
-
-EXTRA_OECONF:ibm-ac-server = " \
- INVSENSOR_YAML_GEN=${STAGING_DIR_HOST}${datadir}/acx22-yaml-config/ipmi-inventory-sensors.yaml \
- " \ No newline at end of file
diff --git a/meta-ibm/recipes-phosphor/packagegroups/packagegroup-op-apps.bbappend b/meta-ibm/recipes-phosphor/packagegroups/packagegroup-op-apps.bbappend
deleted file mode 100644
index 3561360f6f..0000000000
--- a/meta-ibm/recipes-phosphor/packagegroups/packagegroup-op-apps.bbappend
+++ /dev/null
@@ -1 +0,0 @@
-RDEPENDS:${PN}-system:remove:witherspoon = "croserver"
diff --git a/meta-ibm/recipes-phosphor/vpd/openpower-fru-vpd_%.bbappend b/meta-ibm/recipes-phosphor/vpd/openpower-fru-vpd_%.bbappend
deleted file mode 100644
index 5b7b8808ab..0000000000
--- a/meta-ibm/recipes-phosphor/vpd/openpower-fru-vpd_%.bbappend
+++ /dev/null
@@ -1,50 +0,0 @@
-DEPENDS:append:p10bmc = " cli11"
-DEPENDS:append:p10bmc = " nlohmann-json"
-DEPENDS:append:p10bmc = " phosphor-dbus-interfaces"
-DEPENDS:append:p10bmc = " libgpiod"
-
-FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-
-SYSTEMD_SERVICE:${PN}:append:p10bmc = " ibm-vpd-parser@.service"
-SYSTEMD_SERVICE:${PN}:append:p10bmc = " system-vpd.service"
-SYSTEMD_SERVICE:${PN}:append:p10bmc = " com.ibm.VPD.Manager.service"
-SYSTEMD_SERVICE:${PN}:append:p10bmc = " wait-vpd-parsers.service"
-SYSTEMD_SERVICE:${PN}:remove:p10bmc = " op-vpd-parser.service"
-PACKAGECONFIG:append:p10bmc = " ibm-parser vpd-manager"
-
-FILES:${PN}:append:p10bmc = " ${datadir}/vpd/*.json"
-
-do_install:append:p10bmc() {
- # Remove files that are used by openpower-read-vpd
- DEST=${D}${inventory_envdir}
- rm ${DEST}/inventory
- rm ${D}/${nonarch_base_libdir}/udev/rules.d/70-op-vpd.rules
-}
-
-do_install:append:witherspoon() {
- DEST=${D}${inventory_envdir}
- printf "\nEEPROM=/sys/devices/platform/ahb/ahb:apb/ahb:apb:bus@1e78a000/1e78a400.i2c-bus/i2c-11/11-0051/eeprom" >> ${DEST}/inventory
-}
-
-do_install:append:swift() {
- DEST=${D}${inventory_envdir}
- printf "\nEEPROM=/sys/devices/platform/ahb/ahb:apb/ahb:apb:bus@1e78a000/1e78a340.i2c-bus/i2c-8/8-0051/eeprom" >> ${DEST}/inventory
-}
-
-do_install:append:witherspoon-tacoma() {
- DEST=${D}${inventory_envdir}
- printf "FRUS=BMC,ETHERNET" > ${DEST}/inventory
- printf "\nPATHS=/system/chassis/motherboard/bmc,/system/chassis/motherboard/bmc/eth0" >> ${DEST}/inventory
- printf "\nEEPROM=/sys/devices/platform/ahb/ahb:apb/ahb:apb:bus@1e78a000/1e78a600.i2c-bus/i2c-11/11-0051/eeprom" >> ${DEST}/inventory
-}
-
-pkg_postinst:${PN}:p10bmc() {
- mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.wants
- LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.wants/wait-vpd-parsers.service"
- TARGET="../wait-vpd-parsers.service"
- ln -s $TARGET $LINK
-}
-pkg_prerm:${PN}:p10bmc() {
- LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.wants/wait-vpd-parsers.service"
- rm $LINK
-}