summaryrefslogtreecommitdiff
path: root/meta-ibm/recipes-phosphor
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2022-04-27 23:55:11 +0300
committerAndrew Geissler <andrew@geissonator.com>2022-05-03 19:43:17 +0300
commitcc4d085c6b911e4806e6e79d4cc5aa05788504c7 (patch)
treeb4e1948fee1562f7c694bd0b9fa11aa1deec173c /meta-ibm/recipes-phosphor
parentf07620731e55cb8ec3f08803376c6a92192905ca (diff)
downloadopenbmc-cc4d085c6b911e4806e6e79d4cc5aa05788504c7.tar.xz
meta-ibm:state-manager: utilize :append in recipe override
This is the recommended keyword to use and it appears to fix a subtle bug of some sort where the new secure-check is overriding other features. Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: Ic724ec7611741d6286926e96cb0b61530cdcf638
Diffstat (limited to 'meta-ibm/recipes-phosphor')
-rw-r--r--meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend b/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend
index 8072068463..470b8dbc06 100644
--- a/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend
+++ b/meta-ibm/recipes-phosphor/state/phosphor-state-manager_%.bbappend
@@ -3,21 +3,21 @@ EXTRA_OEMESON:append:witherspoon = " -Dwarm-reboot=disabled"
# The scheduled-host-transition package provides support to
# schedule power on and off operations for the host at some
# time in the future. IBM systems will utilize this feature
-RRECOMMENDS:${PN}-host += "${PN}-scheduled-host-transition"
+RRECOMMENDS:${PN}-host:append = " ${PN}-scheduled-host-transition"
# IBM systems track the state of the hypervisor so bring
# in the needed package when the host state package is
# included
-RRECOMMENDS:${PN}-host += "${PN}-hypervisor"
+RRECOMMENDS:${PN}-host:append = " ${PN}-hypervisor"
# IBM p10 machines want the optional secure-check
# feature enabled. This will verify all security
# settings in manufacturing mode.
-RRECOMMENDS:${PN}-host:p10bmc += "${PN}-secure-check"
+RRECOMMENDS:${PN}-host:append:p10bmc = " ${PN}-secure-check"
# IBM systems want the chassis package to not allow a
# system power on if chassis power is in a bad state
-RRECOMMENDS:${PN}-chassis = "${PN}-chassis-check-power-status"
+RRECOMMENDS:${PN}-chassis:append = " ${PN}-chassis-check-power-status"
# Override critical services to monitor with IBM file
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"