summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2022-07-18 19:25:07 +0300
committerAndrew Geissler <andrew@geissonator.com>2022-07-20 22:59:28 +0300
commit15ea0473e94e7f5191178ae1032d753f758122c8 (patch)
tree458b6694929f25f7dc1b2e8bf9d5d2ea06d06597 /meta-ibm
parentf9fd30344ecb77d8e027cddc0c6d6982d1fe9a45 (diff)
downloadopenbmc-15ea0473e94e7f5191178ae1032d753f758122c8.tar.xz
meta-ibm: only install inventory cleanup on ac-server
Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I4e9748641b861f194c66a8fd168901e73c09a51f
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/recipes-phosphor/inventory/inventory-cleanup.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-ibm/recipes-phosphor/inventory/inventory-cleanup.bb b/meta-ibm/recipes-phosphor/inventory/inventory-cleanup.bb
index 1b5a119b1b..f5ef42a31d 100644
--- a/meta-ibm/recipes-phosphor/inventory/inventory-cleanup.bb
+++ b/meta-ibm/recipes-phosphor/inventory/inventory-cleanup.bb
@@ -8,10 +8,10 @@ inherit phosphor-inventory-manager
S = "${WORKDIR}"
-SRC_URI = "file://inventory-cleanup.yaml"
+SRC_URI:append:ibm-ac-server = " file://inventory-cleanup.yaml"
-do_install() {
+do_install:append:ibm-ac-server() {
install -D inventory-cleanup.yaml ${D}${base_datadir}/events.d/inventory-cleanup.yaml
}
-FILES:${PN} += "${base_datadir}/events.d/inventory-cleanup.yaml"
+FILES:${PN}:append:ibm-ac-server = " ${base_datadir}/events.d/inventory-cleanup.yaml"