summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorAli Ahmed <ama213000@gmail.com>2021-10-19 17:45:04 +0300
committerAdriana Kobylak <anoo@linux.ibm.com>2022-08-12 22:27:34 +0300
commitd61875882a7614d5f5ecf8e0863d13668c3a0a2a (patch)
tree17a0871365bd0cbb14918ae0f378ba0114e205ca /meta-ibm
parentcb1f72128d35f4aa88c6f959475713cf1c1a998d (diff)
downloadopenbmc-d61875882a7614d5f5ecf8e0863d13668c3a0a2a.tar.xz
Disable kvm and vm-websocket for p10bmc, tacoma
Note: for witherspoon systems these options are still enabled Tested: 1) Build works for both p10bmc and tacoma 2) Web sockets did not appear and Redfish output was as desired Signed-off-by: Ali Ahmed <ama213000@gmail.com> Change-Id: I0aa710433455b4ca5f17012ecd867846d87a3cfb
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/recipes-phosphor/interfaces/bmcweb_%.bbappend14
1 files changed, 11 insertions, 3 deletions
diff --git a/meta-ibm/recipes-phosphor/interfaces/bmcweb_%.bbappend b/meta-ibm/recipes-phosphor/interfaces/bmcweb_%.bbappend
index 86a0ec2759..1c1ebfb93b 100644
--- a/meta-ibm/recipes-phosphor/interfaces/bmcweb_%.bbappend
+++ b/meta-ibm/recipes-phosphor/interfaces/bmcweb_%.bbappend
@@ -5,11 +5,19 @@ EXTRA_OEMESON:append = " \
-Dredfish-dump-log=enabled \
"
-inherit obmc-phosphor-discovery-service
+EXTRA_OEMESON:append:p10bmc += " \
+ -Dmutual-tls-auth=disabled \
+ -Dkvm=disabled \
+ -Dvm-websocket=disabled \
+"
-EXTRA_OEMESON:append:p10bmc = " -Dmutual-tls-auth=disabled"
+EXTRA_OEMESON:append:witherspoon-tacoma += " \
+ -Dmutual-tls-auth=disabled \
+ -Dkvm=disabled \
+ -Dvm-websocket=disabled \
+"
-EXTRA_OEMESON:append:witherspoon-tacoma = "-Dmutual-tls-auth=disabled"
+inherit obmc-phosphor-discovery-service
REGISTERED_SERVICES:${PN} += "obmc_redfish:tcp:443:"
REGISTERED_SERVICES:${PN} += "obmc_rest:tcp:443:"