summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2021-04-12 15:53:58 +0300
committerVishwanatha Subbanna <vishwa@linux.vnet.ibm.com>2021-04-12 15:53:58 +0300
commit06b43dad66ee0d55e5c53f7ed9f73e59e86dff4a (patch)
treea2546c99548c8c582358191a7190f876ce9aa550 /meta-ibm
parent06dc92d6f1c36c2f0c9b9ca31540c6cd17e515a7 (diff)
downloadopenbmc-06b43dad66ee0d55e5c53f7ed9f73e59e86dff4a.tar.xz
fru-fault-monitor: Enable OperationalStatus monitor feature
Currently, the phosphor-fru-fault-monitor updates the Asserted property of the Led Group D-Bus object by monitoring the `/xyz/openbmc_project/logging` object path. The intent behind this commit is to add another way to monitor the `xyz.openbmc_project.State.Decorator.OperationalStatus` interface of the Inventory D-Bus object, and check whether the Inventory D-Bus object is associated with the LED group D-Bus object, and then update the Asserted property of the LedManager. Since both these methods handle the faults differently, Only ONE of these 2 methods can be enabled and NOT both. The first way is supported by default. To turn OFF the default way AND turn ON this second way, Enable monitor-operational-status. Change-Id: I03701e599b6a120bc1f83da6f473b12f38660d64 Signed-off-by: Vishwanatha Subbanna <vishwa@linux.vnet.ibm.com>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/recipes-phosphor/leds/phosphor-led-manager_%.bbappend5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-ibm/recipes-phosphor/leds/phosphor-led-manager_%.bbappend b/meta-ibm/recipes-phosphor/leds/phosphor-led-manager_%.bbappend
index 0ae5474e87..96a97b040d 100644
--- a/meta-ibm/recipes-phosphor/leds/phosphor-led-manager_%.bbappend
+++ b/meta-ibm/recipes-phosphor/leds/phosphor-led-manager_%.bbappend
@@ -6,8 +6,9 @@ SYSTEMD_SERVICE_${PN}_append_p10bmc += "obmc-led-set-all-groups-asserted@.servic
SYSTEMD_ENVIRONMENT_FILE_${PN}_append_p10bmc +="obmc/led/set-all/groups/config"
# Use the JSON configuration file at runtime than the static led.yaml
-# Also, enable Lamp Test feature for p10bmc systems
-PACKAGECONFIG_append_p10bmc = " use-json use-lamp-test"
+# Also, enable Lamp Test and OperationalStatus monitor feature for
+# p10bmc systems
+PACKAGECONFIG_append_p10bmc = " use-json use-lamp-test monitor-operational-status"
# Install the lamp test override file for p10bmc
SRC_URI_append_p10bmc = " file://lamp-test-led-overrides.json"