summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2023-09-18 16:07:00 +0300
committerAndrew Geissler <geissonator@yahoo.com>2023-09-28 19:20:43 +0300
commit00e81b06686da72b73acfc27b0911fef7df0ae0b (patch)
tree9631b0ecf9d0c11b34b30e378f51f5ae1c8c0d69 /meta-ibm
parent1edbdd483958e93103ff835e02212991dd78007f (diff)
downloadopenbmc-00e81b06686da72b73acfc27b0911fef7df0ae0b.tar.xz
meta-ibm: system1: add systemd-networkd-wait-online
IBM systems do not always configure both eth0 and eth1 ports. This causes this service to fail and hold up the boot of the BMC by the 2 minute timeout. Override this service file to have IBM systems only wait for eth0 OR eth1 to become active. Change-Id: I59b118bc7261bda76b88707426fd216359e08c44 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/recipes-core/systemd/systemd_%.bbappend6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-ibm/recipes-core/systemd/systemd_%.bbappend b/meta-ibm/recipes-core/systemd/systemd_%.bbappend
index b578b8ffc2..fafdad1fa5 100644
--- a/meta-ibm/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-ibm/recipes-core/systemd/systemd_%.bbappend
@@ -11,6 +11,7 @@ SRC_URI:append:p10bmc = " file://network.conf"
SRC_URI:append:genesis3 = " file://systemd-networkd-only-wait-for-one.conf"
SRC_URI:append:sbp1 = " file://systemd-networkd-only-wait-for-one.conf"
+SRC_URI:append:system1 = " file://systemd-networkd-only-wait-for-one.conf"
FILES:${PN}:append:ibm-ac-server = " ${systemd_unitdir}/journald.conf.d/journald-storage-policy.conf"
FILES:${PN}:append:ibm-ac-server = " ${systemd_system_unitdir}/systemd-journald.service.d/systemd-journald-override.conf"
@@ -24,6 +25,7 @@ FILES:${PN}:append:p10bmc = " ${sysconfdir}/sysctl.d/network.conf"
FILES:${PN}:append:genesis3 = " ${systemd_system_unitdir}/systemd-networkd-wait-online.service.d/systemd-networkd-only-wait-for-one.conf"
FILES:${PN}:append:sbp1 = " ${systemd_system_unitdir}/systemd-networkd-wait-online.service.d/systemd-networkd-only-wait-for-one.conf"
+FILES:${PN}:append:system1 = " ${systemd_system_unitdir}/systemd-networkd-wait-online.service.d/systemd-networkd-only-wait-for-one.conf"
do_install:append:ibm-ac-server() {
install -m 644 -D ${WORKDIR}/journald-storage-policy.conf ${D}${systemd_unitdir}/journald.conf.d/journald-storage-policy.conf
@@ -47,6 +49,10 @@ do_install:append:sbp1() {
install -d ${D}${systemd_system_unitdir}/systemd-networkd-wait-online.service.d/
install -m 644 -D ${WORKDIR}/systemd-networkd-only-wait-for-one.conf ${D}${systemd_system_unitdir}/systemd-networkd-wait-online.service.d/systemd-networkd-only-wait-for-one.conf
}
+do_install:append:system1() {
+ install -d ${D}${systemd_system_unitdir}/systemd-networkd-wait-online.service.d/
+ install -m 644 -D ${WORKDIR}/systemd-networkd-only-wait-for-one.conf ${D}${systemd_system_unitdir}/systemd-networkd-wait-online.service.d/systemd-networkd-only-wait-for-one.conf
+}
# Witherspoon doesn't have the space for the both zstd and xz compression
# libraries and currently phosphor-debug-collector is using xz. Switch systemd
# to use xz so only one of the two is added into the image.