summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorAndrew Jeffery <andrew@aj.id.au>2023-06-05 09:46:57 +0300
committerAndrew Jeffery <andrew@aj.id.au>2023-06-06 05:54:36 +0300
commit7a612d4fa70fe6bfd39964c0191a82e6e4546188 (patch)
tree7e1f321d00309272f0b718fb58df510d3bb5bb3c /meta-ibm
parentced2bfd0ecf96fecfb4a1c946ce8465dd4c7524e (diff)
downloadopenbmc-7a612d4fa70fe6bfd39964c0191a82e6e4546188.tar.xz
obmc-console: Convert configs from socket-id to console-id
As of 9a8f30ec5b58 ("obmc-console: Introduce console-id, deprecate socket-id") in obmc-console `console-id` is preferred over `socket-id`. Convert all in-tree configurations to `console-id` to enable removal of support for the deprecated `socket-id` configuration option. Change-Id: Ifd50603c378cfed5eb793b829b8296b7964e4194 Signed-off-by: Andrew Jeffery <andrew@aj.id.au>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/recipes-phosphor/console/obmc-console/p10bmc/client.2201.conf2
-rw-r--r--meta-ibm/recipes-phosphor/console/obmc-console/p10bmc/server.ttyVUART1.conf2
-rw-r--r--meta-ibm/recipes-phosphor/console/obmc-console/witherspoon-tacoma/client.2201.conf2
-rw-r--r--meta-ibm/recipes-phosphor/console/obmc-console/witherspoon-tacoma/server.ttyVUART1.conf2
-rw-r--r--meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend8
5 files changed, 8 insertions, 8 deletions
diff --git a/meta-ibm/recipes-phosphor/console/obmc-console/p10bmc/client.2201.conf b/meta-ibm/recipes-phosphor/console/obmc-console/p10bmc/client.2201.conf
index 7a4459123f..75883d04cf 100644
--- a/meta-ibm/recipes-phosphor/console/obmc-console/p10bmc/client.2201.conf
+++ b/meta-ibm/recipes-phosphor/console/obmc-console/p10bmc/client.2201.conf
@@ -1 +1 @@
-socket-id = hypervisor
+console-id = hypervisor
diff --git a/meta-ibm/recipes-phosphor/console/obmc-console/p10bmc/server.ttyVUART1.conf b/meta-ibm/recipes-phosphor/console/obmc-console/p10bmc/server.ttyVUART1.conf
index 8b3e8caee5..66a0d1e102 100644
--- a/meta-ibm/recipes-phosphor/console/obmc-console/p10bmc/server.ttyVUART1.conf
+++ b/meta-ibm/recipes-phosphor/console/obmc-console/p10bmc/server.ttyVUART1.conf
@@ -1,5 +1,5 @@
lpc-address = 0x2f8
sirq = 3
-socket-id = hypervisor
+console-id = hypervisor
logsize = 256k
logfile = /var/log/obmc-console1.log
diff --git a/meta-ibm/recipes-phosphor/console/obmc-console/witherspoon-tacoma/client.2201.conf b/meta-ibm/recipes-phosphor/console/obmc-console/witherspoon-tacoma/client.2201.conf
index 7a4459123f..75883d04cf 100644
--- a/meta-ibm/recipes-phosphor/console/obmc-console/witherspoon-tacoma/client.2201.conf
+++ b/meta-ibm/recipes-phosphor/console/obmc-console/witherspoon-tacoma/client.2201.conf
@@ -1 +1 @@
-socket-id = hypervisor
+console-id = hypervisor
diff --git a/meta-ibm/recipes-phosphor/console/obmc-console/witherspoon-tacoma/server.ttyVUART1.conf b/meta-ibm/recipes-phosphor/console/obmc-console/witherspoon-tacoma/server.ttyVUART1.conf
index 0bc52cc857..1ec758773c 100644
--- a/meta-ibm/recipes-phosphor/console/obmc-console/witherspoon-tacoma/server.ttyVUART1.conf
+++ b/meta-ibm/recipes-phosphor/console/obmc-console/witherspoon-tacoma/server.ttyVUART1.conf
@@ -1,3 +1,3 @@
lpc-address = 0x2f8
sirq = 3
-socket-id = hypervisor
+console-id = hypervisor
diff --git a/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend b/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend
index b318c88dac..dbcb6ab640 100644
--- a/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend
+++ b/meta-ibm/recipes-phosphor/console/obmc-console_%.bbappend
@@ -6,20 +6,20 @@ SRC_URI += "file://server.ttyVUART0.conf"
install_concurrent_console_config() {
# Install configuration for the servers and clients. Keep commandline
# compatibility with previous configurations by defaulting to not
- # specifying a socket-id for VUART0/2200
+ # specifying a console-id for VUART0/2200
install -m 0755 -d ${D}${sysconfdir}/${BPN}
# Remove the default client configuration as we don't to define a
- # socket-id for the 2200 console
+ # console-id for the 2200 console
rm -f ${D}${sysconfdir}/${BPN}/client.2200.conf
# However, now link to /dev/null as a way of not specifying a
- # socket-id while having a configuration file present. We need to
+ # console-id while having a configuration file present. We need to
# provide a configuration path to meet the requirements of the packaged
# unit file.
ln -sr ${D}/dev/null ${D}${sysconfdir}/${BPN}/client.2200.conf
- # We need to populate socket-id for remaining consoles
+ # We need to populate console-id for remaining consoles
install -m 0644 ${WORKDIR}/client.2201.conf ${D}${sysconfdir}/${BPN}/
# Install configuration for remaining servers - the base recipe