summaryrefslogtreecommitdiff
path: root/meta-ibm
diff options
context:
space:
mode:
authorMyung Bae <myungbae@us.ibm.com>2023-12-05 01:55:07 +0300
committerMyung Bae <myungbae@us.ibm.com>2023-12-08 22:57:48 +0300
commit256bdae0e4b7b9022f6ba1fa4dc0c2f4e4b26587 (patch)
tree106c37c9702584addf161af1995fdfafb1c68720 /meta-ibm
parent5487c9c0399bdaa8a59cf5a77f870ea480e7620b (diff)
downloadopenbmc-256bdae0e4b7b9022f6ba1fa4dc0c2f4e4b26587.tar.xz
meta-ibm: Disable redfish bmc-journal entries
/redfish/v1/Managers/bmc/LogServices/Journal/Entries gives the system journal entries which may be a lot of entries. In addition, if the system clock goes backward while some journal entries were created, redfish validator may potentially complain the failures. Those entries may not be found by `sd_journal_seek_realtime_usec()`[1] which uses bisect search (based on the time order in journal). For example, ``` ERROR - Members: GET of resource at URI /redfish/v1/Managers/bmc/LogServices/Journal/Entries/1699839632005117 returned HTTP error. Check URI. ERROR - Members: GET of resource at URI /redfish/v1/Managers/bmc/LogServices/Journal/Entries/1699839632053933 returned HTTP error. Check URI. ERROR - Members: GET of resource at URI /redfish/v1/Managers/bmc/LogServices/Journal/Entries/1699839632056655 returned HTTP error. Check URI. ``` Journal entries are ``` { "MESSAGE_ID" : "39f53479d3a045ac8e11786248231fbf", "MESSAGE" : "Started Time & Date Service.", "__REALTIME_TIMESTAMP" : "1699839632179843", "_SOURCE_REALTIME_TIMESTAMP" : "1699839632179536", } ---Backward Begin { "_SOURCE_REALTIME_TIMESTAMP" : "1699839632004914", "MESSAGE" : "Clock change detected. Flushing caches.", "__REALTIME_TIMESTAMP" : "1699839632005117", } { "MESSAGE" : "Time jumped backwards, rotating.", "__REALTIME_TIMESTAMP" : "1699839632053933", } { "__REALTIME_TIMESTAMP" : "1699839632056655", "MESSAGE_ID" : "c7a787079b354eaaa9e77b371893cd27", "MESSAGE" : "Changed local time to Mon 2023-11-13 01:40:32 UTC", "_SOURCE_REALTIME_TIMESTAMP" : "1699839632018027", } ---End of backward { "__REALTIME_TIMESTAMP" : "1699839662049861", "MESSAGE_ID" : "7ad2d189f7e94e70a38c781354912448", "_SOURCE_REALTIME_TIMESTAMP" : "1699839662049794", "MESSAGE" : "systemd-timedated.service: Deactivated successfully.", } ``` Tested: - Redfish Validator passes - GET Journal Entries will not be found ``` $ curl -k -X GET https://${bmc}:18080/redfish/v1/Managers/bmc/LogServices/Journal/Entries { "error": { "@Message.ExtendedInfo": [ { "@odata.type": "#Message.v1_1_1.Message", "Message": "The requested resource of type named 'Entries' was not found.", "MessageArgs": [ "", "Entries" ], "MessageId": "Base.1.16.0.ResourceNotFound", "MessageSeverity": "Critical", "Resolution": "Provide a valid resource identifier and resubmit the request." } ], "code": "Base.1.16.0.ResourceNotFound", "message": "The requested resource of type named 'Entries' was not found." } } ``` [1] https://github.com/openbmc/bmcweb/blob/7164bc62dd26ec92b01985aaae97ecc48276dea5/redfish-core/lib/log_services.hpp#L2690 Change-Id: I778e3ff1e0d3de508d33a1d53aed5e57ca096f37 Signed-off-by: Myung Bae <myungbae@us.ibm.com>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/recipes-phosphor/interfaces/bmcweb_%.bbappend1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/interfaces/bmcweb_%.bbappend b/meta-ibm/recipes-phosphor/interfaces/bmcweb_%.bbappend
index 952f4bb16c..38cd7405db 100644
--- a/meta-ibm/recipes-phosphor/interfaces/bmcweb_%.bbappend
+++ b/meta-ibm/recipes-phosphor/interfaces/bmcweb_%.bbappend
@@ -5,6 +5,7 @@ EXTRA_OEMESON:append = " \
-Dredfish-dump-log=enabled \
-Dredfish-oem-manager-fan-data=disabled \
-Dbmcweb-logging=error \
+ -Dredfish-bmc-journal=disabled \
"
EXTRA_OEMESON:append:p10bmc = " \