summaryrefslogtreecommitdiff
path: root/meta-ibs/meta-cp2-5422/recipes-phosphor
diff options
context:
space:
mode:
authoreportnov <eportnov@ibs.ru>2022-07-08 16:54:42 +0300
committereportnov <eportnov@ibs.ru>2022-07-08 16:54:42 +0300
commiteb04be2006d5354551fade1ed59bcb0c3a890841 (patch)
treee65531474993bc2fbd27d0b44061ebeaa7409f97 /meta-ibs/meta-cp2-5422/recipes-phosphor
parentd08a2a08a454b0861f973df7e42b32d78c6ec166 (diff)
downloadopenbmc-eb04be2006d5354551fade1ed59bcb0c3a890841.tar.xz
Add new fields to dimm
Diffstat (limited to 'meta-ibs/meta-cp2-5422/recipes-phosphor')
-rw-r--r--meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm/dimm0.yaml6
-rw-r--r--meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm/dimm1.yaml6
-rw-r--r--meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm/dimm2.yaml6
-rw-r--r--meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm/dimm3.yaml6
-rw-r--r--meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/0002-add-new-dimm-fields.patch29
-rw-r--r--meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue_%.bbappend1
6 files changed, 54 insertions, 0 deletions
diff --git a/meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm/dimm0.yaml b/meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm/dimm0.yaml
index 6331d50b00..531c6686b0 100644
--- a/meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm/dimm0.yaml
+++ b/meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm/dimm0.yaml
@@ -14,6 +14,12 @@ events:
MemoryTypeDetail:
value: "Synchronous, Static column"
type: string
+ Description:
+ value: "This is description"
+ type: string
+ Model:
+ value: "Kingston FURY Beast Black"
+ type: string
- name: createObjects
objs:
diff --git a/meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm/dimm1.yaml b/meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm/dimm1.yaml
index 8f245821ca..0ea51971cf 100644
--- a/meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm/dimm1.yaml
+++ b/meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm/dimm1.yaml
@@ -14,6 +14,12 @@ events:
MemoryTypeDetail:
value: "Synchronous, Static column"
type: string
+ Description:
+ value: "This is description"
+ type: string
+ Model:
+ value: "Kingston FURY Beast Black"
+ type: string
- name: createObjects
objs:
diff --git a/meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm/dimm2.yaml b/meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm/dimm2.yaml
index 1bf7d867a0..e9e8e15802 100644
--- a/meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm/dimm2.yaml
+++ b/meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm/dimm2.yaml
@@ -14,6 +14,12 @@ events:
MemoryTypeDetail:
value: "Synchronous, Static column"
type: string
+ Description:
+ value: "This is description"
+ type: string
+ Model:
+ value: "Kingston FURY Beast Black"
+ type: string
- name: createObjects
objs:
diff --git a/meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm/dimm3.yaml b/meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm/dimm3.yaml
index e1dfb1e4d9..48eca62db3 100644
--- a/meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm/dimm3.yaml
+++ b/meta-ibs/meta-cp2-5422/recipes-phosphor/inventory/phosphor-inventory-manager-dimm/dimm3.yaml
@@ -14,6 +14,12 @@ events:
MemoryTypeDetail:
value: "Synchronous, Static column"
type: string
+ Description:
+ value: "This is description"
+ type: string
+ Model:
+ value: "Kingston FURY Beast Black"
+ type: string
- name: createObjects
objs:
diff --git a/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/0002-add-new-dimm-fields.patch b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/0002-add-new-dimm-fields.patch
new file mode 100644
index 0000000000..0b3cdd6475
--- /dev/null
+++ b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue/0002-add-new-dimm-fields.patch
@@ -0,0 +1,29 @@
+From b2fed2b2735851248931753a70e8135318b51661 Mon Sep 17 00:00:00 2001
+From: eportnov <eportnov@ibs.ru>
+Date: Fri, 8 Jul 2022 16:40:06 +0300
+Subject: [PATCH] add new dimm fields
+
+---
+ src/store/modules/HardwareStatus/MemoryStore.js | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/store/modules/HardwareStatus/MemoryStore.js b/src/store/modules/HardwareStatus/MemoryStore.js
+index fd8f0a9..ff0b00f 100644
+--- a/src/store/modules/HardwareStatus/MemoryStore.js
++++ b/src/store/modules/HardwareStatus/MemoryStore.js
+@@ -26,6 +26,7 @@ const MemoryStore = {
+ SparePartNumber,
+ Description,
+ MemoryType,
++ Model,
+ MemorySize,
+ LocationIndicatorActive,
+ Location,
+@@ -45,6 +46,7 @@ const MemoryStore = {
+ sparePartNumber: SparePartNumber,
+ description: Description,
+ memoryType: MemoryType,
++ model: Model,
+ memorySize: MemorySize,
+ identifyLed: LocationIndicatorActive,
+ uri: data['@odata.id'],
diff --git a/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue_%.bbappend b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue_%.bbappend
index 6f219c4e21..5d4737c597 100644
--- a/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue_%.bbappend
+++ b/meta-ibs/meta-cp2-5422/recipes-phosphor/webui/webui-vue_%.bbappend
@@ -14,6 +14,7 @@ SRCREV = "72b0bc1e6cbec314f6c6298a61e03b9db343e47e"
SRC_URI += "\
file://favicon.ico \
file://0001-IBS-html-head-title.patch \
+ file://0002-add-new-dimm-fields.patch \
"
do_update_logo () {