summaryrefslogtreecommitdiff
path: root/meta-intel-openbmc
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2022-01-25 00:55:09 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-01-25 19:37:00 +0300
commitbb99d22ecef61f3af21290b1e1ead3083f25d20f (patch)
treeaa8d74352697b6ace7a098ce59b791ab65fc6714 /meta-intel-openbmc
parent897b7444e5ee1ce045b536aa822f20a95c5dd63d (diff)
downloadopenbmc-bb99d22ecef61f3af21290b1e1ead3083f25d20f.tar.xz
treewide: fix up github SRC_URIs
Per [1], Yocto is going to start requiring both branch names and `protocol=https` in GitHub SRC_URI variables. Ran the upstream tool to automatically fix our URIs. 1. https://git.yoctoproject.org/poky/tree/documentation/migration-guides/migration-3.5.rst#n10 Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I5f9619f7ff707050b469ae74c8aa16846568c5e4
Diffstat (limited to 'meta-intel-openbmc')
-rw-r--r--meta-intel-openbmc/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb2
-rw-r--r--meta-intel-openbmc/meta-common/recipes-core/libpeci/libpeci_git.bb2
-rwxr-xr-xmeta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb2
-rw-r--r--meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb2
-rw-r--r--meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb2
5 files changed, 5 insertions, 5 deletions
diff --git a/meta-intel-openbmc/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb b/meta-intel-openbmc/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb
index 5b0e733b74..bd97696af2 100644
--- a/meta-intel-openbmc/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb
+++ b/meta-intel-openbmc/meta-common/recipes-core/host-error-monitor/host-error-monitor_git.bb
@@ -2,7 +2,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
inherit cmake systemd
-SRC_URI = "git://github.com/openbmc/host-error-monitor"
+SRC_URI = "git://github.com/openbmc/host-error-monitor;branch=master;protocol=https"
DEPENDS = "boost sdbusplus libgpiod libpeci"
diff --git a/meta-intel-openbmc/meta-common/recipes-core/libpeci/libpeci_git.bb b/meta-intel-openbmc/meta-common/recipes-core/libpeci/libpeci_git.bb
index dd7ddbe69c..b41d8b12f3 100644
--- a/meta-intel-openbmc/meta-common/recipes-core/libpeci/libpeci_git.bb
+++ b/meta-intel-openbmc/meta-common/recipes-core/libpeci/libpeci_git.bb
@@ -5,7 +5,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
inherit cmake
-SRC_URI = "git://github.com/openbmc/libpeci"
+SRC_URI = "git://github.com/openbmc/libpeci;branch=master;protocol=https"
PV = "0.1+git${SRCPV}"
SRCREV = "bdefaa3c95d0a93928f8ebda1ce158172d3a4bcf"
diff --git a/meta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb b/meta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
index e8f0c2ccf4..225593a523 100755
--- a/meta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
+++ b/meta-intel-openbmc/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "Intel OEM IPMI commands"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=a6a4edad4aed50f39a66d098d74b265b"
-SRC_URI = "git://github.com/openbmc/intel-ipmi-oem"
+SRC_URI = "git://github.com/openbmc/intel-ipmi-oem;branch=master;protocol=https"
SRCREV = "382dc97f87325ead8e8ee57a430127af34780736"
S = "${WORKDIR}/git"
diff --git a/meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb b/meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb
index e90235bab4..a18c2c0720 100644
--- a/meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb
+++ b/meta-intel-openbmc/meta-common/recipes-intel/pfr/pfr-manager_git.bb
@@ -5,7 +5,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
inherit cmake systemd
-SRC_URI = "git://github.com/openbmc/pfr-manager"
+SRC_URI = "git://github.com/openbmc/pfr-manager;branch=master;protocol=https"
PV = "0.1+git${SRCPV}"
SRCREV = "57f42c3d37d9546ede4f2c015bf9f392130c93b5"
diff --git a/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
index 637b70b222..ed5447d5bf 100644
--- a/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
+++ b/meta-intel-openbmc/meta-common/recipes-phosphor/dbus/intel-dbus-interfaces_git.bb
@@ -14,7 +14,7 @@ inherit phosphor-dbus-yaml
DEPENDS += "autoconf-archive-native"
DEPENDS += "${PYTHON_PN}-sdbus++-native"
-SRC_URI = "git://github.com/openbmc/intel-dbus-interfaces"
+SRC_URI = "git://github.com/openbmc/intel-dbus-interfaces;branch=master;protocol=https"
SRCREV = "2b1255c47fdaaee6fd2db8f38f32abc13a7edf05"
PACKAGECONFIG ??= "libintel_dbus"