summaryrefslogtreecommitdiff
path: root/meta-nuvoton/recipes-bsp
diff options
context:
space:
mode:
authorBrian Ma <chma0@nuvoton.com>2023-05-10 09:49:35 +0300
committerTim Lee <chli30@nuvoton.com>2023-07-04 08:37:59 +0300
commit816dbb7809f44006b99a03a4b61c75a0e6dca7dc (patch)
tree985d117db09f59942d33d6ef340f732ade6404cd /meta-nuvoton/recipes-bsp
parent2a1e461a98a74229bab8decf68b9d79bb1555253 (diff)
downloadopenbmc-816dbb7809f44006b99a03a4b61c75a0e6dca7dc.tar.xz
meta-nuvoton: Add build wic image support
We add wks file and relative config for build wic image. Now user can build wic image by include phosphor-mmc.inc. And set WKS_RWFS_SIZE, WKS_RWFS_SIZE to adjust eMMC parition size instead of create new wks file for each board. Change-Id: I1ed342658d791fd9011bd31ea6db36d4362d120b Signed-off-by: Brian Ma <chma0@nuvoton.com>
Diffstat (limited to 'meta-nuvoton/recipes-bsp')
-rw-r--r--meta-nuvoton/recipes-bsp/u-boot/files/u-boot-emmc.cfg5
-rw-r--r--meta-nuvoton/recipes-bsp/u-boot/u-boot-nuvoton_git.bb4
2 files changed, 8 insertions, 1 deletions
diff --git a/meta-nuvoton/recipes-bsp/u-boot/files/u-boot-emmc.cfg b/meta-nuvoton/recipes-bsp/u-boot/files/u-boot-emmc.cfg
new file mode 100644
index 0000000000..4bc6522423
--- /dev/null
+++ b/meta-nuvoton/recipes-bsp/u-boot/files/u-boot-emmc.cfg
@@ -0,0 +1,5 @@
+CONFIG_CMD_EXT4=y
+CONFIG_CMD_FS_GENERIC=y
+CONFIG_CMD_GPT=y
+CONFIG_CMD_PART=y
+CONFIG_CMD_UNZIP=y
diff --git a/meta-nuvoton/recipes-bsp/u-boot/u-boot-nuvoton_git.bb b/meta-nuvoton/recipes-bsp/u-boot/u-boot-nuvoton_git.bb
index 3ecb4a457a..d4c4697509 100644
--- a/meta-nuvoton/recipes-bsp/u-boot/u-boot-nuvoton_git.bb
+++ b/meta-nuvoton/recipes-bsp/u-boot/u-boot-nuvoton_git.bb
@@ -1,4 +1,4 @@
-DESCRIPTION = "U-boot for Nuvoton NPCM7xx Baseboard Management Controller"
+DESCRIPTION = "U-boot for Nuvoton NPCM7xx/NPCM8xx Baseboard Management Controller"
require u-boot-common-nuvoton.inc
require u-boot-nuvoton.inc
@@ -6,3 +6,5 @@ require u-boot-nuvoton.inc
PROVIDES += "u-boot"
DEPENDS += "dtc-native"
+
+SRC_URI:append:df-phosphor-mmc = " file://u-boot-emmc.cfg"