summaryrefslogtreecommitdiff
path: root/meta-nuvoton
diff options
context:
space:
mode:
authorTim Lee <timlee660101@gmail.com>2022-08-16 09:39:24 +0300
committerTim Lee <timlee660101@gmail.com>2022-08-19 04:27:03 +0300
commitd7f1523ce82444717223aef344501da7255861c4 (patch)
treef96fc1dcefec92ccf90cdd549f686efda7e92143 /meta-nuvoton
parent84e4cfe4c0d3986a5c7ad58ce87d316624bcc4b3 (diff)
downloadopenbmc-d7f1523ce82444717223aef344501da7255861c4.tar.xz
meta-nuvoton: add npcm8xx-tip-fw recipe
The Arbel NPCM8XX requires a TIP FW image which handles various security tasks. Releases/TIP_FW_L0_0.4.1_L1_0.2.6 version: 1. Flash driver bug fixes. 2. Bug fix CS1 slew rate. 3. Print all SFDP info. Signed-off-by: Tim Lee <timlee660101@gmail.com> Change-Id: I54c0c7b46972b7a261c5d8c73472ae57c2346fb7
Diffstat (limited to 'meta-nuvoton')
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.4.1.0.2.6.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.4.1.0.2.6.bb b/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.4.1.0.2.6.bb
new file mode 100644
index 0000000000..bec7a3f3f2
--- /dev/null
+++ b/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.4.1.0.2.6.bb
@@ -0,0 +1,26 @@
+SUMMARY = "TIP FW for NPCM8XX (Arbel) devices"
+DESCRIPTION = "TIP FW for NPCM8XX (Arbel) devices"
+HOMEPAGE = "https://github.com/Nuvoton-Israel/npcm8xx-tip-fw"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=650b869bd8ff2aed59c62bad2a22a821"
+
+FILENAME = "Kmt_TipFwL0_Skmt_TipFwL1_${PV}.bin"
+
+S = "${WORKDIR}"
+
+SRCREV = "04e43fbacdc55860153444e04672097e3f2b29fa"
+SRC_URI = " \
+ https://github.com/Nuvoton-Israel/npcm8xx-tip-fw/${SRCREV}/LICENSE;name=lic \
+ https://github.com/Nuvoton-Israel/npcm8xx-tip-fw/releases/download/TIP_FW_L0_0.4.1_L1_0.2.6/Kmt_TipFwL0_Skmt_TipFwL1.bin;downloadfilename=${FILENAME};name=bin \
+"
+
+SRC_URI[lic.sha256sum] = "7c34d28e784b202aa4998f477fd0aa9773146952d7f6fa5971369fcdda59cf48"
+SRC_URI[bin.sha256sum] = "669f03ff336dd168cd7a6098fb2c6dd413f3f4703460acfc795ab9ff975d1458"
+
+inherit deploy
+
+do_deploy () {
+ install -D -m 644 ${WORKDIR}/${FILENAME} ${DEPLOYDIR}/Kmt_TipFwL0_Skmt_TipFwL1.bin
+}
+
+addtask deploy before do_build after do_compile