summaryrefslogtreecommitdiff
path: root/meta-nuvoton
diff options
context:
space:
mode:
authorTim Lee <timlee660101@gmail.com>2023-02-03 05:57:55 +0300
committerTim Lee <chli30@nuvoton.com>2023-02-07 09:39:23 +0300
commit332ee51c0d8de048704c31cacc78c8d3aaf77b54 (patch)
tree8602bfadff61d7dd01b1897b208b7715098c20aa /meta-nuvoton
parent4ef4348a4498db9618c12118f8a9f0fde05f00ed (diff)
downloadopenbmc-332ee51c0d8de048704c31cacc78c8d3aaf77b54.tar.xz
meta-nuvoton: npcm8xx-tip-fw: modify recipe more clearer to maintain
Change to use TIPFW binary file from git repository directly that make recipe more clearer to maintain in the future upgrade. Signed-off-by: Tim Lee <timlee660101@gmail.com> Change-Id: Icc413ced0ea3f92f9866647b11642a1191853082
Diffstat (limited to 'meta-nuvoton')
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw.inc15
-rw-r--r--meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.5.3.0.4.2.bb6
2 files changed, 4 insertions, 17 deletions
diff --git a/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw.inc b/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw.inc
index 40eec80f90..6a9983ac52 100644
--- a/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw.inc
+++ b/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw.inc
@@ -4,21 +4,14 @@ HOMEPAGE = "https://github.com/Nuvoton-Israel/npcm8xx-tip-fw"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=f789971f29c65e31dbb33ed209b4dc91"
-FILENAME = "Kmt_TipFwL0_Skmt_TipFwL1_${OUTPUT_BIN}.bin"
+TIP_FW = "Kmt_TipFwL0_Skmt_TipFwL1.bin"
+S = "${WORKDIR}/git"
-S = "${WORKDIR}"
-
-SRC_URI = " \
- https://github.com/Nuvoton-Israel/npcm8xx-tip-fw/raw/${SRCREV}/LICENSE;name=lic \
- https://github.com/Nuvoton-Israel/npcm8xx-tip-fw/raw/${SRCREV}/${OUTPUT_BIN}/Kmt_TipFwL0_Skmt_TipFwL1.bin;downloadfilename=${FILENAME};name=${OUTPUT_BIN} \
-"
-
-SRC_URI[lic.sha256sum] = "84f16976acf8bdb73798989594d8547419096fb9be29a0fd84d1eba0fd550049"
+SRC_URI = "git://github.com/Nuvoton-Israel/npcm8xx-tip-fw;branch=main;protocol=https"
inherit deploy
-
do_deploy () {
- install -D -m 644 ${WORKDIR}/${FILENAME} ${DEPLOYDIR}/Kmt_TipFwL0_Skmt_TipFwL1.bin
+ install -D -m 644 ${OUTPUT_BIN}/${TIP_FW} ${DEPLOYDIR}/${TIP_FW}
}
addtask deploy before do_build after do_compile
diff --git a/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.5.3.0.4.2.bb b/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.5.3.0.4.2.bb
index 8494c4c45e..53c47b953d 100644
--- a/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.5.3.0.4.2.bb
+++ b/meta-nuvoton/recipes-bsp/images/npcm8xx-tip-fw_0.5.3.0.4.2.bb
@@ -2,10 +2,4 @@ SRCREV = "e9bc9838f49402c185bf987dab362e5a938cdd5a"
OUTPUT_BIN = "output_binaries_${DEVICE_GEN}_${IGPS_MACHINE}"
-SRC_URI[output_binaries_A1_EB.sha256sum] = "5ea2f796ee2a917700f9a8d0e2bc7a2fa6c540573df81956cb9a73aba3bfd2e0"
-SRC_URI[output_binaries_A1_Google.sha256sum] = "c07d740093b0599e76463456c5b0a2325a9da9fa99cae2f7a349a68f837e60d1"
-SRC_URI[output_binaries_A1_SVB.sha256sum] = "57af59c6e2cfb7cc91865aa9fc434ac57fa39ecee51cb63c07d0ba56bc21526f"
-SRC_URI[output_binaries_Z1_EB.sha256sum] = "9ab9e17f7502fbe5d7a17a4e4f29614f369c799ba2896e8428b31bd4a2a765e0"
-SRC_URI[output_binaries_Z1_SVB.sha256sum] = "3c23d41421706f0f14db239b474811bdff9d39564c6a618304ab56bcd706550c"
-
require npcm8xx-tip-fw.inc