summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-gnome/recipes-support
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-08-26 08:32:28 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-08-26 08:32:33 +0300
commit665fd026517259031fd55bcfb2a9dab0d9f3582a (patch)
tree4152d42430b07cd519c82b91d9c1abc88b5a5a6a /meta-openembedded/meta-gnome/recipes-support
parent36166cd035bf51c6830b977e48316d708daa62b5 (diff)
downloadopenbmc-665fd026517259031fd55bcfb2a9dab0d9f3582a.tar.xz
meta-openembedded: subtree update:509d40153d..1e8bc46e55
Adrian Bunk (5): networkmanager: musl now supports secure_getenv libuser: musl now supports secure_getenv libgit2: Upgrade 0.27.8 -> 0.27.9 poppler: Stop using USE_FIXEDPOINT networkmanager: Upgrade 1.18.0 -> 1.18.2 Andreas Müller (10): xfce4-time-out-plugin: upgrade 1.0.2 -> 1.0.3 xfce4-battery-plugin: 1.1.2 -> 1.1.3 xfce4-smartbookmark-plugin: upgrade 0.5.0 -> 0.5.1 xfce4-wavelan-plugin: upgrade 0.6.0 -> 0.6.1 xfce4-netload-plugin: upgrade 1.3.1 -> 1.3.2 xfce4-systemload-plugin: upgrade 1.2.2 -> 1.2.3 xfce4-mpc-plugin: upgrade 0.5.1 -> 0.5.2 xfce4-fsguard-plugin: upgrade 1.1.0 -> 1.1.1 xfce4-diskperf-plugin: upgrade 2.6.1 -> 2.6.2 gigolo: upgrade 0.4.2 -> 0.5.0 Anuj Mittal (2): clinfo: add recipe ade: add recipe Hongxu Jia (1): lvm2: fix circular dependencies while systemd enable cryptsetup Jan Kaisrlik (1): networkd-dispatcher: service file is using different location of binary Johannes Pointner (1): libtinyxml2: update to 7.1.0 Martin Jansa (1): python-socketio: prevent python2 socketio depending on python3-aiohttp Piotr Tworek (3): libgee: Update to version 0.20.2 gnome-bluetooth: Update to version 3.32.1. gnome-keyring: Update to version 3.28.2 Yi Zhao (1): apache2: upgrade 2.4.39 -> 2.4.41 Yuan Chao (5): libnftnl: upgrade 1.1.3 -> 1.1.4 libtdb: upgrade 1.4.0 -> 1.4.1 python-flask-pymongo: upgrade 0.5.1 -> 2.3.0 xfsprogs: upgrade 5.2.0 -> 5.2.1 python-protobuf: upgrade 3.9.0 -> 3.9.1 Zang Ruochen (1): cryptsetup: upgrade 2.1.0 -> 2.2.0. Change-Id: I4db480893fc3b39cc7e014dbca0adc9c5317abf1 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-gnome/recipes-support')
-rw-r--r--meta-openembedded/meta-gnome/recipes-support/libuser/libuser/0001-Check-for-issetugid.patch62
-rw-r--r--meta-openembedded/meta-gnome/recipes-support/libuser/libuser_0.62.bb1
2 files changed, 0 insertions, 63 deletions
diff --git a/meta-openembedded/meta-gnome/recipes-support/libuser/libuser/0001-Check-for-issetugid.patch b/meta-openembedded/meta-gnome/recipes-support/libuser/libuser/0001-Check-for-issetugid.patch
deleted file mode 100644
index 79756b9a07..0000000000
--- a/meta-openembedded/meta-gnome/recipes-support/libuser/libuser/0001-Check-for-issetugid.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From d0537cb7f2dc5877700ad78dfd191515379d4edc Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 7 Jan 2016 02:22:51 +0000
-Subject: [PATCH 1/2] Check for issetugid()
-
-If secure version of getenv is not there then we can use
-issetugid() as aid to call getenv()
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
-Upstream-Status: Pending
-
- configure.ac | 1 +
- lib/config.c | 12 +++++++++++-
- 2 files changed, 12 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 1ded1a2..ee19e1f 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -125,6 +125,7 @@ AC_TYPE_OFF_T
- AC_TYPE_SIZE_T
-
- AC_CHECK_FUNCS([__secure_getenv secure_getenv])
-+AC_CHECK_FUNCS([issetugid])
-
- # Modify CFLAGS after all tests are run (some of them could fail because
- # of the -Werror).
-diff --git a/lib/config.c b/lib/config.c
-index 29e7120..30f9daf 100644
---- a/lib/config.c
-+++ b/lib/config.c
-@@ -44,8 +44,10 @@
- # define safe_getenv(string) secure_getenv(string)
- #elif defined(HAVE___SECURE_GETENV)
- # define safe_getenv(string) __secure_getenv(string)
-+#elif defined(HAVE_ISSETUGID)
-+# define safe_getenv(string) safe_getenv_issetugid(string)
- #else
--# error Neither secure_getenv not __secure_getenv are available
-+# error None of secure_getenv, __secure_getenv, or issetugid is available
- #endif
-
- struct config_config {
-@@ -59,6 +61,14 @@ struct config_key {
- GList *values;
- };
-
-+static const char*
-+safe_getenv_issetugid(const char* name)
-+{
-+ if (issetugid ())
-+ return 0;
-+ return getenv (name);
-+}
-+
- /* Compare two section names */
- static int
- compare_section_names(gconstpointer a, gconstpointer b)
---
-2.7.0
-
diff --git a/meta-openembedded/meta-gnome/recipes-support/libuser/libuser_0.62.bb b/meta-openembedded/meta-gnome/recipes-support/libuser/libuser_0.62.bb
index 7ec54eb16e..74053e451a 100644
--- a/meta-openembedded/meta-gnome/recipes-support/libuser/libuser_0.62.bb
+++ b/meta-openembedded/meta-gnome/recipes-support/libuser/libuser_0.62.bb
@@ -12,7 +12,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
SECTION = "base"
SRC_URI = "https://releases.pagure.org/libuser/libuser-${PV}.tar.xz \
- file://0001-Check-for-issetugid.patch \
file://0002-remove-unused-execinfo.h.patch \
file://0001-modules-files.c-parse_field-fix-string-formating-in-.patch \
"