summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-networking/recipes-support/rdma-core
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2020-01-21 15:31:46 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2020-01-21 15:31:57 +0300
commit0e2770ca218e5a902986a5ec9529c6a6877cacf1 (patch)
tree8ddaef8df38fe420fea652943c45e99135702574 /meta-openembedded/meta-networking/recipes-support/rdma-core
parente2375b556f8744dbfb57f561cfa7c6e67df63474 (diff)
downloadopenbmc-0e2770ca218e5a902986a5ec9529c6a6877cacf1.tar.xz
meta-openembedded: subtree update:ea8604a0e3..d0748372d2
Adrian Bunk (1): libnih: Remove Alexander Kanavin (3): sysprof: add a recipe from oe-core sysprof: update to 3.34.1 sysprof: fix ARM builds Andreas Müller (2): evolution-data-server: remove pythonnative from inherit fontforge: rework for python3 Diego Rondini (2): cups-filters: use libexecdir and cleanup cups-filters: upgrade 1.26.0 -> 1.26.2 Gianfranco Costamagna (2): websocketpp: refresh clang patch vboxguestdrivers: update to new version 6.1.2 Khem Raj (14): sysprof: avoid namesapace conflict with glibc headers jack: Use c++ compiler for programs which use c++ source files iozone3: Do not define prototype for pread64() libhugetlbfs: Fix missing file mode in create() API rdma-core: Use overloadable attribute with clang sysprof: Correct systemdunitdir location opencv: Tend for the compiler --param option rename in gcc10 grpc: Link with libatomic on powerpc ssiapi: Needs boost/ppc support fluentbit: Fix build on powerpc mozjs: extend --with-intl-api=build to ppc mpv: Disable lua support on powerpc packagegroup-meta-oe: Remove unbuildable recipes for ppc64le from rdeps opensc: Upgrade to 0.20.0 Mingde (Matthew) Zeng (2): byacc: upgrade 20191103 -> 20191125 keyutils: upgrade 1.6 -> 1.6.1 Peter Kjellerstedt (1): gitpkgv.bbclass: Add support for extending the supported tag formats S. Lockwood-Childs (1): lcov: geninfo needs another perl module Wang Mingyu (15): python3-cheetah: upgrade 3.2.3 -> 3.2.4 python3-coverage: 4.4.2 -> 5.0.2 python3-keras-applications: upgrade 1.0.6 -> 1.0.8 python3-keras-preprocessing: upgrade 1.0.5 -> 1.1.0 python3-more-itertools: 7.2.0 -> 8.1.0 python3-multidict: 4.5.2 -> 4.7.4 python3-ordered-set: 3.0.1 -> 3.1.1 python3-pulsectl: upgrade 18.12.5 -> 20.1.2 python-cmd2: upgrade 0.9.22 -> 0.9.23 python-engineio: upgrade 3.11.1 -> 3.11.2 python-javaobj-py3: upgrade 0.3.0 -> 0.4.0.1 python-kconfiglib: upgrade 10.42.0 -> 13.7.0 python-packaging: 19.2 -> 20.0 python-periphery: 2.0.0 -> 2.0.1 python-pyrsistent: upgrade 0.15.5 -> 0.15.7 William A. Kennington III via Openembedded-devel (1): cppzmq: bump to version 4.6.0 Yi Zhao (3): crda: fix UDEV_RULE_DIR open-vm-tools: fix build error with usrmerge feature multipath-tools: fix libudevdir Zang Ruochen (14): dhcpcd: upgrade 8.1.1 -> 8.1.5 fio: upgrade 3.16 -> 3.17 libencode-perl: upgrade 3.01 -> 3.02 zabbix: modify service file libmicrohttpd: upgrade 0.9.68 -> 0.9.69 libsass: upgrade 3.6.1 -> 3.6.3 pcsc-lite: upgrade 1.8.25 -> 1.8.26 python3-yarl: upgrade 1.3.0 -> 1.4.2 python3-wheel: upgrade 0.32.3 -> 0.33.6 python3-websockets: upgrade 8.0.2 -> 8.1 python-wcwidth: upgrade 0.1.7 -> 0.1.8 python-waitress: upgrade 1.4.1 -> 1.4.2 python-tqdm: upgrade 4.38.0 -> 4.41.1 python-supervisor: upgrade 4.0.2 -> 4.1.0 Change-Id: I2c394941fc3140bfeadcec3542cd72892fdcda6e Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-networking/recipes-support/rdma-core')
-rw-r--r--meta-openembedded/meta-networking/recipes-support/rdma-core/rdma-core/0001-Use-overloadable-attribute-with-clang.patch42
-rw-r--r--meta-openembedded/meta-networking/recipes-support/rdma-core/rdma-core_27.0.bb1
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-openembedded/meta-networking/recipes-support/rdma-core/rdma-core/0001-Use-overloadable-attribute-with-clang.patch b/meta-openembedded/meta-networking/recipes-support/rdma-core/rdma-core/0001-Use-overloadable-attribute-with-clang.patch
new file mode 100644
index 0000000000..1ba6847d2f
--- /dev/null
+++ b/meta-openembedded/meta-networking/recipes-support/rdma-core/rdma-core/0001-Use-overloadable-attribute-with-clang.patch
@@ -0,0 +1,42 @@
+From 42976ed0a0160864b41680604ea9cdb3c175cb94 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 15 Jan 2020 17:48:28 -0800
+Subject: [PATCH] Use overloadable attribute with clang
+
+This is overriding the libc implementation
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ librdmacm/preload.c | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/librdmacm/preload.c b/librdmacm/preload.c
+index d46beb1b..b451de50 100644
+--- a/librdmacm/preload.c
++++ b/librdmacm/preload.c
+@@ -59,6 +59,12 @@
+ #include "cma.h"
+ #include "indexer.h"
+
++#ifdef __clang__
++#define OVERLOAD __attribute__((overloadable))
++#else
++#define OVERLOAD
++#endif
++
+ struct socket_calls {
+ int (*socket)(int domain, int type, int protocol);
+ int (*bind)(int socket, const struct sockaddr *addr, socklen_t addrlen);
+@@ -793,7 +799,7 @@ ssize_t recv(int socket, void *buf, size_t len, int flags)
+ rrecv(fd, buf, len, flags) : real.recv(fd, buf, len, flags);
+ }
+
+-ssize_t recvfrom(int socket, void *buf, size_t len, int flags,
++ssize_t OVERLOAD recvfrom(int socket, void *buf, size_t len, int flags,
+ struct sockaddr *src_addr, socklen_t *addrlen)
+ {
+ int fd;
+--
+2.25.0
+
diff --git a/meta-openembedded/meta-networking/recipes-support/rdma-core/rdma-core_27.0.bb b/meta-openembedded/meta-networking/recipes-support/rdma-core/rdma-core_27.0.bb
index 361d69b337..417979dc33 100644
--- a/meta-openembedded/meta-networking/recipes-support/rdma-core/rdma-core_27.0.bb
+++ b/meta-openembedded/meta-networking/recipes-support/rdma-core/rdma-core_27.0.bb
@@ -9,6 +9,7 @@ BRANCH = "stable-v${@d.getVar('PV').split('.')[0]}"
SRC_URI = "git://github.com/linux-rdma/rdma-core.git;branch=${BRANCH} \
file://0001-Remove-man-files-which-cant-be-built.patch \
file://0001-librdmacm-Use-sched_yield-instead-of-pthread_yield.patch \
+ file://0001-Use-overloadable-attribute-with-clang.patch \
"
SRCREV = "84caf035ae6123e2296b72006cd2cf698c65eb46"
S = "${WORKDIR}/git"