summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-bsp
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-02 20:29:27 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-02 20:29:31 +0300
commit36a3e3e747c6df39fc2e3910b72a40c0bd7f3c7d (patch)
tree9480192d0cca5018cf5a364d4931b90694b96aec /meta-openembedded/meta-oe/recipes-bsp
parent63417d1f540c12c3e0b456409555ecbe50f39875 (diff)
downloadopenbmc-36a3e3e747c6df39fc2e3910b72a40c0bd7f3c7d.tar.xz
meta-openembedded: subtree update:41fe46157c..e6d76b05a7
Adrian Bunk (1): networkmanager: Correct the upstream version check Adrian Ratiu (1): renderdoc: add new recipe Changqing Li (1): kea: upgrade 1.5.0 -> 1.7.0 Denys Dmytriyenko (1): rwmem: add recipe Hongxu Jia (1): lvm2: fix run lvcreate hung while PACKAGECONFIG udev Jackie Huang (6): python-versiontools: add recipes for python2 and python3 python-pymysql: add recipes for python2 and python3 python-statistics: add new recipe python-pyperf: add recipes for python2 and python3 python-pika: add recipes for python2 and python3 python-pycurl: add recipes for python2 and python3 Khem Raj (6): openipmi: Mark libOpenIPMI.so.0 as private lib in openipmi-perl ttf-gentium: Use OFL-1.0 version of OFL license ttf-hunkyfonts: Use LGPL-2.1 which is correct version from LICENSE file python-configparser: Mark license as MIT fontforge: Upgrade to 20190801 release opensaf: Fix duplicate copies of shared libs in package Martin Jansa (2): spice: ignore all warnings not just address-of-packed-member Revert "spice: Drop broken native" Otavio Salvador (5): networkmanager: Fix ADSL plugin packaging networkmanager: Add a `resolvconf` PACKAGECONFIG networkmanager: Add sysvinit support libqmi: Upgrade 1.22.2 -> 1.24.0 modemmanager: Upgrade 1.10.0 -> 1.10.2 Qi.Chen@windriver.com (1): protobuf-c: fix race condition Robert Yang (2): corosync: Fix PACKAGECONFIG flag for rdma net-snmp: Fix PACKAGECONFIG for perl Zang Ruochen (1): python-urllib3: upgrade 1.25.5 -> 1.25.6 Change-Id: I20029cc79a225f6ab8f1b133ebc16129b7b32082 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-bsp')
-rw-r--r--meta-openembedded/meta-oe/recipes-bsp/rwmem/rwmem_1.2.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-bsp/rwmem/rwmem_1.2.bb b/meta-openembedded/meta-oe/recipes-bsp/rwmem/rwmem_1.2.bb
new file mode 100644
index 0000000000..0a15134df8
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-bsp/rwmem/rwmem_1.2.bb
@@ -0,0 +1,26 @@
+SUMMARY = "A small tool to read/write memory"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS += "python3 python3-pybind11"
+
+PV .= "+git${SRCPV}"
+
+SRCREV_rwmem = "cc296c5366a35a4c4271cfa3cc9831f6f34bfd9d"
+SRCREV_inih = "4b10c654051a86556dfdb634c891b6c3224c4109"
+
+SRCREV_FORMAT = "rwmem_inih"
+
+SRC_URI = " \
+ git://github.com/tomba/rwmem.git;protocol=https;name=rwmem \
+ git://github.com/benhoyt/inih.git;protocol=https;name=inih;nobranch=1;destsuffix=git/ext/inih \
+"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+do_install() {
+ install -D -m 0755 ${B}/bin/rwmem ${D}${bindir}/rwmem
+ install -D -m 0644 ${B}/lib/librwmem.a ${D}${libdir}/librwmem.a
+}