summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-devtools/lua
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-14 18:06:18 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-14 18:06:23 +0300
commit00ab237b1727155ac1fe8bc97ab3579439f98407 (patch)
tree343ef47048ef2f3d5a4da7e5b2301b737ae74247 /meta-openembedded/meta-oe/recipes-devtools/lua
parent3e6b296400821b1e59b416242b3c9f952710731e (diff)
downloadopenbmc-00ab237b1727155ac1fe8bc97ab3579439f98407.tar.xz
meta-openembedded: subtree update:fd1a0c9210..1bfaa2e63a
Alex Kiernan (1): ostree: Upgrade 2019.3 -> 2019.4 Alexander Kanavin (1): lua: change a hard readline dependency into an optional one Andreas Müller (5): catfish: upgrade 1.4.9 -> 1.4.10 polkit-group-rules: Fix error in do_rootfs for rpm package-manager jack: upgrade 1.9.12 -> 1.9.13 fluidsynth: upgrade 2.0.6 -> 2.0.7 xfce4-panel: upgrade 4.14.0 -> 4.14.1 Bartosz Golaszewski (3): networkd-dispatcher: use distro_features_check to check for systemd networkd-dispatcher: remove unneeded RDEPENDS networkd-dispatcher: inherit systemd class Changqing Li (1): multipath-tools: upgrade 0.8.1 -> 0.8.2 Hongxu Jia (1): lvm2: remove unsupported OPTIONS+="event_timeout" rule Khem Raj (6): nvme-cli: Use install-spec target jsonrpc: Disable coverage in default build bdwgc: Enable C++ support and Additional options for musl a2jmidid: Fix build on risv tinyalsa: Update to latest packagegroup-meta-multimedia: Remove libsquish from rdeps Martin Schwan (1): python-waitress: Add recipes Paul Eggleton (1): mosquitto: update to 1.6.7 Peiran Hong (1): tcpdump: Delete unused patch Peter Kjellerstedt (1): kconfig-frontends: Retrieve the Git repository from GitLab Randy MacLeod (1): rwmem: add DESCRIPTION since the summary is vague Trevor Gamblin (1): rsyslog: fix CVE-2019-17040 Zang Ruochen (7): firewalld: upgrade 0.7.1 -> 0.7.2 fetchmail: upgrade 6.3.26 -> 6.4.1 python-asn1crypto: upgrade 0.24.0 -> 1.0.1 python-attrs: upgrade 19.1.0 -> 19.2.0 python-beautifulsoup4: upgrade 4.8.0 -> 4.8.1 python-cmd2: upgrade 0.9.17 -> 0.9.18 python-jinja2: upgrade 2.10.1 -> 2.10.3 Change-Id: Ief2d129403b43b308c19093ac63a498c8d51eb50 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-devtools/lua')
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/lua/lua/0001-Allow-building-lua-without-readline-on-Linux.patch59
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/lua/lua_5.3.5.bb9
2 files changed, 65 insertions, 3 deletions
diff --git a/meta-openembedded/meta-oe/recipes-devtools/lua/lua/0001-Allow-building-lua-without-readline-on-Linux.patch b/meta-openembedded/meta-oe/recipes-devtools/lua/lua/0001-Allow-building-lua-without-readline-on-Linux.patch
new file mode 100644
index 0000000000..e767900864
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-devtools/lua/lua/0001-Allow-building-lua-without-readline-on-Linux.patch
@@ -0,0 +1,59 @@
+From 601ef636fc4dfb2af3e7fda88d8ea1c1d92affe4 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Wed, 2 Oct 2019 17:54:15 +0200
+Subject: [PATCH] Allow building lua without readline on Linux
+
+Upstream-Status: Pending
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ Makefile | 2 +-
+ src/Makefile | 3 +++
+ src/luaconf.h | 5 +++++
+ 3 files changed, 9 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 119110d..9f6df45 100644
+--- a/Makefile
++++ b/Makefile
+@@ -36,7 +36,7 @@ RM= rm -f
+ # == END OF USER SETTINGS -- NO NEED TO CHANGE ANYTHING BELOW THIS LINE =======
+
+ # Convenience platforms targets.
+-PLATS= aix bsd c89 freebsd generic linux macosx mingw posix solaris
++PLATS= aix bsd c89 freebsd generic linux linux-no-readline macosx mingw posix solaris
+
+ # What to install.
+ TO_BIN= lua luac
+diff --git a/src/Makefile b/src/Makefile
+index 64c78f7..5c0428a 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -109,6 +109,9 @@ generic: $(ALL)
+ linux:
+ $(MAKE) $(ALL) SYSCFLAGS="-DLUA_USE_LINUX" SYSLIBS="-Wl,-E -ldl -lreadline"
+
++linux-no-readline:
++ $(MAKE) $(ALL) SYSCFLAGS="-DLUA_USE_LINUX_NO_READLINE" SYSLIBS="-Wl,-E -ldl"
++
+ macosx:
+ $(MAKE) $(ALL) SYSCFLAGS="-DLUA_USE_MACOSX" SYSLIBS="-lreadline"
+
+diff --git a/src/luaconf.h b/src/luaconf.h
+index 9eeeea6..d71ca25 100644
+--- a/src/luaconf.h
++++ b/src/luaconf.h
+@@ -64,6 +64,11 @@
+ #define LUA_USE_READLINE /* needs some extra libraries */
+ #endif
+
++#if defined(LUA_USE_LINUX_NO_READLINE)
++#define LUA_USE_POSIX
++#define LUA_USE_DLOPEN /* needs an extra library: -ldl */
++#endif
++
+
+ #if defined(LUA_USE_MACOSX)
+ #define LUA_USE_POSIX
+--
+2.17.1
+
diff --git a/meta-openembedded/meta-oe/recipes-devtools/lua/lua_5.3.5.bb b/meta-openembedded/meta-oe/recipes-devtools/lua/lua_5.3.5.bb
index 265e2519e0..ae41e627f0 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/lua/lua_5.3.5.bb
+++ b/meta-openembedded/meta-oe/recipes-devtools/lua/lua_5.3.5.bb
@@ -4,9 +4,9 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://doc/readme.html;beginline=318;endline=352;md5=60aa5cfdbd40086501778d9b6ebf29ee"
HOMEPAGE = "http://www.lua.org/"
-DEPENDS = "readline"
SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz;name=tarballsrc \
file://lua.pc.in \
+ file://0001-Allow-building-lua-without-readline-on-Linux.patch \
"
# if no test suite matches PV release of Lua exactly, download the suite for the closest Lua release.
@@ -24,18 +24,21 @@ SRC_URI[tarballtest.sha256sum] = "b80771238271c72565e5a1183292ef31bd7166414cd0d4
inherit pkgconfig binconfig ptest
+PACKAGECONFIG ??= "readline"
+PACKAGECONFIG[readline] = ",,readline"
+
UCLIBC_PATCHES += "file://uclibc-pthread.patch"
SRC_URI_append_libc-uclibc = "${UCLIBC_PATCHES}"
TARGET_CC_ARCH += " -fPIC ${LDFLAGS}"
-EXTRA_OEMAKE = "'CC=${CC} -fPIC' 'MYCFLAGS=${CFLAGS} -DLUA_USE_LINUX -fPIC' MYLDFLAGS='${LDFLAGS}'"
+EXTRA_OEMAKE = "'CC=${CC} -fPIC' 'MYCFLAGS=${CFLAGS} -fPIC' MYLDFLAGS='${LDFLAGS}'"
do_configure_prepend() {
sed -i -e s:/usr/local:${prefix}:g src/luaconf.h
}
do_compile () {
- oe_runmake linux
+ oe_runmake ${@bb.utils.contains('PACKAGECONFIG', 'readline', 'linux', 'linux-no-readline', d)}
}
do_install () {