summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-devtools/protobuf
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-07 21:58:51 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-10-01 20:14:20 +0300
commit757e94a3dfd7ec792c01e3ecee295ea987955f5a (patch)
tree72fd9de1db26f666b0138c39fa150d8b8b0e8f07 /meta-openembedded/meta-oe/recipes-devtools/protobuf
parent4a2471930c63da38cbea2270a313f1610274f7ba (diff)
downloadopenbmc-757e94a3dfd7ec792c01e3ecee295ea987955f5a.tar.xz
meta-openembedded: sumo refresh be79b8b111..2bb21ef27c
Update meta-openembedded to sumo HEAD. Armin Kuster (1): grpc: move it from oe to networking layer Khem Raj (2): gedit: Add dep on python-six-native poppler: Update to 0.64 Martin Jansa (2): libqb: Fix build with gold openocd: prevent fetching git submodules during do_configure Nicolas Dechesne (1): meta-multimedia: fixup LAYERDEPENDS Paul Eggleton (1): protobuf: make python-protobuf dependency optional and default to off Sinan Kaya (1): dnsmasq: CVE-2017-15107 Takuro Ashie (1): uim: Fix SRC_URI Change-Id: I611fc4019b8a7fcbcaf2bcca40d7e35a650e5120 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-devtools/protobuf')
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf_3.5.1.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf_3.5.1.bb b/meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf_3.5.1.bb
index 1ffb79da71..073dfaef05 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf_3.5.1.bb
+++ b/meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf_3.5.1.bb
@@ -12,7 +12,7 @@ DEPENDS = "zlib"
DEPENDS_append_class-target = " protobuf-native"
RDEPENDS_${PN}-compiler = "${PN}"
RDEPENDS_${PN}-dev += "${PN}-compiler"
-RDEPENDS_${PN}-ptest = "bash python-protobuf"
+RDEPENDS_${PN}-ptest = "bash ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python-protobuf', '', d)}"
LIC_FILES_CHKSUM = "file://LICENSE;md5=35953c752efc9299b184f91bef540095"
@@ -24,13 +24,16 @@ SRC_URI = "git://github.com/google/protobuf.git;branch=3.5.x \
file://run-ptest \
"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[python] = ",,"
+
EXTRA_OECONF += " --with-protoc=echo"
inherit autotools-brokensep pkgconfig ptest
S = "${WORKDIR}/git"
TEST_SRC_DIR="examples"
-LANG_SUPPORT="cpp python"
+LANG_SUPPORT = "cpp ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}"
do_compile_ptest() {
# Modify makefile to use the cross-compiler