summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-02 20:29:27 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-10-02 20:29:31 +0300
commit36a3e3e747c6df39fc2e3910b72a40c0bd7f3c7d (patch)
tree9480192d0cca5018cf5a364d4931b90694b96aec /meta-openembedded/meta-oe/recipes-devtools
parent63417d1f540c12c3e0b456409555ecbe50f39875 (diff)
downloadopenbmc-36a3e3e747c6df39fc2e3910b72a40c0bd7f3c7d.tar.xz
meta-openembedded: subtree update:41fe46157c..e6d76b05a7
Adrian Bunk (1): networkmanager: Correct the upstream version check Adrian Ratiu (1): renderdoc: add new recipe Changqing Li (1): kea: upgrade 1.5.0 -> 1.7.0 Denys Dmytriyenko (1): rwmem: add recipe Hongxu Jia (1): lvm2: fix run lvcreate hung while PACKAGECONFIG udev Jackie Huang (6): python-versiontools: add recipes for python2 and python3 python-pymysql: add recipes for python2 and python3 python-statistics: add new recipe python-pyperf: add recipes for python2 and python3 python-pika: add recipes for python2 and python3 python-pycurl: add recipes for python2 and python3 Khem Raj (6): openipmi: Mark libOpenIPMI.so.0 as private lib in openipmi-perl ttf-gentium: Use OFL-1.0 version of OFL license ttf-hunkyfonts: Use LGPL-2.1 which is correct version from LICENSE file python-configparser: Mark license as MIT fontforge: Upgrade to 20190801 release opensaf: Fix duplicate copies of shared libs in package Martin Jansa (2): spice: ignore all warnings not just address-of-packed-member Revert "spice: Drop broken native" Otavio Salvador (5): networkmanager: Fix ADSL plugin packaging networkmanager: Add a `resolvconf` PACKAGECONFIG networkmanager: Add sysvinit support libqmi: Upgrade 1.22.2 -> 1.24.0 modemmanager: Upgrade 1.10.0 -> 1.10.2 Qi.Chen@windriver.com (1): protobuf-c: fix race condition Robert Yang (2): corosync: Fix PACKAGECONFIG flag for rdma net-snmp: Fix PACKAGECONFIG for perl Zang Ruochen (1): python-urllib3: upgrade 1.25.5 -> 1.25.6 Change-Id: I20029cc79a225f6ab8f1b133ebc16129b7b32082 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-devtools')
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf-c/0001-avoid-race-condition.patch36
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.2.bb1
2 files changed, 37 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf-c/0001-avoid-race-condition.patch b/meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf-c/0001-avoid-race-condition.patch
new file mode 100644
index 0000000000..4fc7703d81
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf-c/0001-avoid-race-condition.patch
@@ -0,0 +1,36 @@
+From 216e31260b618ec73862f9f5336597f391444dac Mon Sep 17 00:00:00 2001
+From: Chen Qi <Qi.Chen@windriver.com>
+Date: Sun, 29 Sep 2019 17:20:42 +0800
+Subject: [PATCH] avoid race condition
+
+It's possible that the cxx-generate-packed-data.cc is compiled
+while the t/test-full.pb.h is being generated. This will result
+the following error.
+
+ DEBUG: ./t/test-full.pb.h:4:0: error: unterminated #ifndef
+ ./t/test-full.pb.h:4:0: error: unterminated #ifndef
+
+Add a dependency to avoid such problem.
+
+Upstream-Status: Pending
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+---
+ Makefile.am | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.am b/Makefile.am
+index b0cb065..1608ae0 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -156,6 +156,7 @@ noinst_PROGRAMS += \
+ t_generated_code2_cxx_generate_packed_data_SOURCES = \
+ t/generated-code2/cxx-generate-packed-data.cc \
+ t/test-full.pb.cc
++t/generated-code2/cxx-generate-packed-data.cc: t/test-full.pb.h
+ $(t_generated_code2_cxx_generate_packed_data_OBJECTS): t/test-full.pb.h
+ t_generated_code2_cxx_generate_packed_data_CXXFLAGS = \
+ $(AM_CXXFLAGS) \
+--
+2.17.1
+
diff --git a/meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.2.bb b/meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.2.bb
index 6d1ffc3f40..b92f82dec2 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.2.bb
+++ b/meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf-c_1.3.2.bb
@@ -15,6 +15,7 @@ DEPENDS = "protobuf-native protobuf"
SRCREV = "1390409f4ee4e26d0635310995b516eb702c3f9e"
SRC_URI = "git://github.com/protobuf-c/protobuf-c.git \
+ file://0001-avoid-race-condition.patch \
"
S = "${WORKDIR}/git"