summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-08-20 16:15:15 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-08-20 16:15:22 +0300
commit90ca747aa04f375af7ff86462a52028245b174b9 (patch)
treefb660879f07363805138d821882c4092ac47c047 /meta-openembedded/meta-oe/recipes-devtools
parent0b251f46569493f7a028b31031e50316dd584299 (diff)
downloadopenbmc-90ca747aa04f375af7ff86462a52028245b174b9.tar.xz
meta-openembedded: subtree update: c95842cdca..509d40153d
Andreas Müller (13): xfce4-whiskermenu-plugin: upgrade 2.3.2 -> 2.3.3 xfmpc: upgrade 0.2.3 -> 0.3.0 xfce4-cpugraph-plugin: upgrade 1.0.5 -> 1.1.0 xfce4-terminal: upgrase 0.8.7.4 -> 0.8.8 gtksourceview3: upgrade 3.24.10 -> 3.24.11 mousepad: move to gtk3 mousepad: upgrade 0.4.1 -> 0.4.2 ristretto: upgrade 0.8.4 -> 0.10.0 catfish: upgrade 1.4.7 -> 1.4.8 xfce4-datetime-plugin: upgrade 0.7.1 -> 0.8.0 xfce4-places-plugin: 1.8.0 -> 1.8.1 xfce4-pulseaudio-plugin: upgrade 0.4.1 -> 0.4.2 parole: upgrade 1.0.2 -> 1.0.4 Brad Bishop (1): cli11: Remove dev pkg dep to main pkg Kai Kang (1): packagegroup-tools-bluetooth: correct RDEPENDS Khem Raj (8): libopus: Limit forcing ARM mode ISA to v5 only mime-construct,libextutils-parsexs-perl: add runtime dependency on perl webmin: Add perl to rdeps for modules hplip: Add python to rdeps klibc: Disable bcmp builtin for clang on glibc as well python3-blivet: Add python3 to rdeps grubby: Add bash to rdeps ufs-tool: Do not force static linking Martin Jansa (10): nodejs: fix QA error about /usr/bin/python dependency iotop: add runtime dependency on python-core freeradius: add runtime dependency on perl scsirastools: add runtime dependency on bash libcec: add runtime dependency on python3-core dnf-plugin-tui: add runtime dependency on bash edac-utils: add runtime dependency on perl lmsensors: add runtime dependency on bash libdbi-perl: add runtime dependency on perl scsirastools: add runtime dependency on bash II Piotr Tworek (4): telepathy-glib: Update to version 0.24.1 telepathy-glib: Enable vala bindings gnome-themes-standard: Update to version 3.28 libgdata: Update to version 0.17.10. Slater, Joseph (1): php: zlib and zip support Yuan Chao (3): xfsprogs: upgrade 5.1.0 -> 5.2.0 xfsdump: fix error to work with xfsprogs 5.2.0 python-pymongo: upgrade 3.8.0 -> 3.9.0 Change-Id: I9450310b0c5abd766ecd0ee21c9338159b36e940 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-devtools')
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/dnf-plugin-tui/dnf-plugin-tui_git.bb25
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/nodejs/nodejs_10.16.2.bb2
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/perl/libdbi-perl_1.642.bb1
-rw-r--r--meta-openembedded/meta-oe/recipes-devtools/php/php.inc4
4 files changed, 18 insertions, 14 deletions
diff --git a/meta-openembedded/meta-oe/recipes-devtools/dnf-plugin-tui/dnf-plugin-tui_git.bb b/meta-openembedded/meta-oe/recipes-devtools/dnf-plugin-tui/dnf-plugin-tui_git.bb
index e891868cda..a8367b5d91 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/dnf-plugin-tui/dnf-plugin-tui_git.bb
+++ b/meta-openembedded/meta-oe/recipes-devtools/dnf-plugin-tui/dnf-plugin-tui_git.bb
@@ -14,25 +14,26 @@ inherit distutils3-base
S = "${WORKDIR}/git"
do_install_append() {
- install -d ${D}${datadir}/dnf
- install -m 0755 ${S}/samples/* ${D}${datadir}/dnf
- install -d ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins/mkimg
- install -m 0755 ${S}/dnf-plugins/mkimg/* ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins/mkimg
- for file in $(ls ${S}/dnf-plugins/ | grep -v mkimg); do
- install -m 0755 ${S}/dnf-plugins/$file ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins
- done
+ install -d ${D}${datadir}/dnf
+ install -m 0755 ${S}/samples/* ${D}${datadir}/dnf
+ install -d ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins/mkimg
+ install -m 0755 ${S}/dnf-plugins/mkimg/* ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins/mkimg
+ for file in $(ls ${S}/dnf-plugins/ | grep -v mkimg); do
+ install -m 0755 ${S}/dnf-plugins/$file ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins
+ done
}
do_install_append_class-target() {
- install -d ${D}${sysconfdir}/yum.repos.d
- install -m 0644 ${WORKDIR}/oe-remote.repo.sample ${D}${sysconfdir}/yum.repos.d
+ install -d ${D}${sysconfdir}/yum.repos.d
+ install -m 0644 ${WORKDIR}/oe-remote.repo.sample ${D}${sysconfdir}/yum.repos.d
}
FILES_${PN} += "${datadir}/dnf"
RDEPENDS_${PN} += " \
- dnf \
- libnewt-python \
- "
+ bash \
+ dnf \
+ libnewt-python \
+"
BBCLASSEXTEND = "nativesdk"
diff --git a/meta-openembedded/meta-oe/recipes-devtools/nodejs/nodejs_10.16.2.bb b/meta-openembedded/meta-oe/recipes-devtools/nodejs/nodejs_10.16.2.bb
index e259c45bea..d464e9d8af 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/nodejs/nodejs_10.16.2.bb
+++ b/meta-openembedded/meta-oe/recipes-devtools/nodejs/nodejs_10.16.2.bb
@@ -100,7 +100,7 @@ do_install_append_class-target() {
PACKAGES =+ "${PN}-npm"
FILES_${PN}-npm = "${exec_prefix}/lib/node_modules ${bindir}/npm ${bindir}/npx"
-RDEPENDS_${PN}-npm = "bash python python-shell python-datetime python-subprocess python-textutils \
+RDEPENDS_${PN}-npm = "bash python-core python-shell python-datetime python-subprocess python-textutils \
python-compiler python-misc python-multiprocessing"
PACKAGES =+ "${PN}-systemtap"
diff --git a/meta-openembedded/meta-oe/recipes-devtools/perl/libdbi-perl_1.642.bb b/meta-openembedded/meta-oe/recipes-devtools/perl/libdbi-perl_1.642.bb
index 91f94a1aa0..7532b3fa22 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/perl/libdbi-perl_1.642.bb
+++ b/meta-openembedded/meta-oe/recipes-devtools/perl/libdbi-perl_1.642.bb
@@ -28,6 +28,7 @@ do_install_prepend() {
}
RDEPENDS_${PN}_class-target = " \
+ perl \
perl-module-carp \
perl-module-exporter \
perl-module-exporter-heavy \
diff --git a/meta-openembedded/meta-oe/recipes-devtools/php/php.inc b/meta-openembedded/meta-oe/recipes-devtools/php/php.inc
index 785c2f5acc..4c0617c49c 100644
--- a/meta-openembedded/meta-oe/recipes-devtools/php/php.inc
+++ b/meta-openembedded/meta-oe/recipes-devtools/php/php.inc
@@ -47,7 +47,7 @@ EXTRA_OECONF = "--enable-mbstring \
--enable-fpm \
--with-libdir=${baselib} \
--with-gettext=${STAGING_LIBDIR}/.. \
- --with-libzip=${STAGING_LIBDIR}/.. \
+ --with-zlib=${STAGING_LIBDIR}/.. \
--with-iconv=${STAGING_LIBDIR}/.. \
--with-bz2=${STAGING_DIR_TARGET}${exec_prefix} \
--with-config-file-path=${sysconfdir}/php/apache2-php${PHP_MAJOR_VERSION} \
@@ -69,6 +69,8 @@ PACKAGECONFIG ??= "mysql sqlite3 imap opcache openssl \
"
PACKAGECONFIG_class-native = ""
+PACKAGECONFIG[zip] = "--enable-zip --with-libzip=${STAGING_EXECPREFIXDIR},,libzip"
+
PACKAGECONFIG[mysql] = "--with-mysql=${STAGING_DIR_TARGET}${prefix} \
--with-mysqli=${STAGING_BINDIR_CROSS}/mysql_config \
--with-pdo-mysql=${STAGING_BINDIR_CROSS}/mysql_config \