summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-security/usbguard
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2023-01-30 22:28:01 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-01-30 23:15:34 +0300
commitb9af8750acfaddd4a8b99c3e289510b5476c90f3 (patch)
tree53385dd5fc99ccf4869c9c80fcd1e98e100fe81f /meta-openembedded/meta-oe/recipes-security/usbguard
parent70d69cd8440d2a940a971f262a3e36cc78781461 (diff)
downloadopenbmc-b9af8750acfaddd4a8b99c3e289510b5476c90f3.tar.xz
subtree updates
meta-security: 3d9dab6d14..7eed4a60f5: Armin Kuster (2): linux-yocto.bbappend: bump to kernel version 6.x meta-tpm: bump linux-yocto to 6.x kernel Max Krummenacher (1): samhain: rework due to changed cache handling meta-openembedded: 2ab113e8be..ea63f13846: Beniamin Sandu (1): mbedtls: export source files/headers needed by ATF Khem Raj (13): poco: Do not use std::atomic<bool> libwebsockets: Fix build with gcc13 v4l-utils: Fix build with gcc13 proj: Upgrade to 9.1.1 release mpd: Upgrade to 0.23.12 release geos: Upgrade to 3.9.4 geos: Fix build with gcc13 libinih: Upgrade to version 56 python3-pybind11: Upgrade to 2.10.3 waylandpp: Fix build with gcc-13 sedutil: Fix build with gcc13 usbguard: Fix build with gcc13 minifi-cpp: Fix build with gcc13 Martin Jansa (6): keyutils: fix Upstream-Status formatting gphoto2: fix Upstream-Status formatting .patch: fix Upstream-Status formatting issues reported by patchreview tool from oe-core android-tools: fix Upstream-Status formatting mm-common: fix Upstream-Status formatting .patch: fix Signed-off-by formatting issues reported by patchreview tool from oe-core poky: 5e249ec855..29afbb5e14: Alejandro Hernandez Samaniego (1): newlib: Upgrade 4.2.0 -> 4.3.0 Alexander Kanavin (1): gdk-pixbuf: do not use tools from gdk-pixbuf-native when building tests Armin Kuster (1): lttng-modules: Fix for 5.10.163 kernel version Khem Raj (3): valgrind: Include missing <cstdint> webkitgtk: Fix build with gcc 13 gdb: Define alignof using _Alignof when using C11 or newer Richard Purdie (3): make-mod-scripts: Ensure kernel build output is deterministic bitbake.conf: Inject a dash into PN for BB_HASH_CODEPARSER_VALS scripts/bitbake-prserv-tool: Fix to work with memres bitbake Ross Burton (1): Revert "cve-update-db-native: show IP on failure" meta-arm: 3d51e1117d..aecbb77f72: Jon Mason (4): arm/qemuarm-secureboot: Changes for v2023.01 u-boot arm-bsp/juno: update to use u-boot v2023.01 arm-bsp/juno: update kernel patches for 6.1 arm-bsp/fvp-base: update kernel config to remove warning Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Ia335876b7ce9a4c9d19ca41ae321b266b3b6d00e
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-security/usbguard')
-rw-r--r--meta-openembedded/meta-oe/recipes-security/usbguard/usbguard/0001-include-missing-cstdint.patch45
-rw-r--r--meta-openembedded/meta-oe/recipes-security/usbguard/usbguard_1.1.2.bb1
2 files changed, 46 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-security/usbguard/usbguard/0001-include-missing-cstdint.patch b/meta-openembedded/meta-oe/recipes-security/usbguard/usbguard/0001-include-missing-cstdint.patch
new file mode 100644
index 0000000000..5cbe64091c
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-security/usbguard/usbguard/0001-include-missing-cstdint.patch
@@ -0,0 +1,45 @@
+From 1da0cfbb9ae978822d961d8b22d8d5125c11247a Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 26 Jan 2023 23:46:56 -0800
+Subject: [PATCH] include missing <cstdint>
+
+gcc 13 moved some includes around and as a result <cstdint> is no
+longer transitively included [1]. Explicitly include it for
+uint8_t.
+
+[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
+
+Upstream-Status: Submitted [https://github.com/USBGuard/usbguard/pull/583]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/Library/Base64.cpp | 1 -
+ src/Library/Base64.hpp | 1 +
+ 2 files changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Library/Base64.cpp b/src/Library/Base64.cpp
+index ddb28dc..0246a13 100644
+--- a/src/Library/Base64.cpp
++++ b/src/Library/Base64.cpp
+@@ -22,7 +22,6 @@
+
+ #include "Base64.hpp"
+ #include <stdexcept>
+-#include <cstdint>
+
+ namespace usbguard
+ {
+diff --git a/src/Library/Base64.hpp b/src/Library/Base64.hpp
+index 0947f21..e0c745c 100644
+--- a/src/Library/Base64.hpp
++++ b/src/Library/Base64.hpp
+@@ -23,6 +23,7 @@
+ #endif
+
+ #include <string>
++#include <cstdint>
+ #include <cstddef>
+
+ namespace usbguard
+--
+2.39.1
+
diff --git a/meta-openembedded/meta-oe/recipes-security/usbguard/usbguard_1.1.2.bb b/meta-openembedded/meta-oe/recipes-security/usbguard/usbguard_1.1.2.bb
index e1e087a6d0..4e96b4f41e 100644
--- a/meta-openembedded/meta-oe/recipes-security/usbguard/usbguard_1.1.2.bb
+++ b/meta-openembedded/meta-oe/recipes-security/usbguard/usbguard_1.1.2.bb
@@ -12,6 +12,7 @@ LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
SRC_URI = "https://github.com/USBGuard/usbguard/releases/download/${BPN}-${PV}/${BPN}-${PV}.tar.gz \
+ file://0001-include-missing-cstdint.patch \
file://0001-Add-and-use-pkgconfig-instead-of-libgcrypt-config.patch"
SRC_URI[sha256sum] = "dcf5c90f3f93030e04df1baeb8d388b678c40dd48b135ea12a7be7dee8944934"