summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/dfu-util
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-23 15:01:31 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-23 16:18:15 +0300
commitdec060e0fadb20cc708370ae192db4462283ee58 (patch)
treec239cdb9a5f7c4f0f022babb75115b5a5eb0e69c /meta-openembedded/meta-oe/recipes-support/dfu-util
parentaca8d6e0500430a0cba0b1ebd1099cd709bafcc1 (diff)
downloadopenbmc-dec060e0fadb20cc708370ae192db4462283ee58.tar.xz
meta-openembedded: subtree update:ef1b17f4ef..290ad988fb
Alistair Francis (6): python3-padaos: Initial commit of version 0.1.10 python3-padatious: Initial commit of 0.4.7 python3-petact: Initial commit of version 0.1.2 python3-precise-runner: Initial commit of version 0.3.1 python3-pulsectl: Initial version of 18.12.5 python3-pychromecast: Initial commit of version 4.0.1 Bartosz Golaszewski (1): python-jsonschema: add python-setuptools-scm to RDEPENDS Daniel Ammann (1): dhex: Add new recipe Khem Raj (5): dfu-utils: Switch src_uri to sourceforge.net dfu-util-native: Dont build static binary live555: Switch SRC_URI where archives are kept for longer kernel-selftest: Exclude from world builds uim: Update to 1.8.8 Oleksandr Kravchuk (2): pcsc-lite: update to 1.8.25 xf86-video-nouveau: update to 1.0.16 Ricardo Salveti (2): python-pyrsistent: add recipe python-jsonschema: rdepends on attrs and pyrsistent S. Lockwood-Childs (1): wireshark: remove restriction to ARM ISA Slater, Joseph (1): live555: update to version 20190828 Vincent Prince (3): python*-psutil: Add native and nativesdk to BBCLASSEXTEND python3-cheetah: add recipe python3-regex: add recipe Yuan Chao (8): python-more-itertools: new recipe python-zipp: new recipe python-pathlib2: new recipe python-packaging: new recipe python-importlib-metadata: new recipe python-pytest: fix runtime error libtevent: upgrade 0.10.0 -> 0.10.1 cryptsetup: upgrade 2.2.0 -> 2.2.1 cjhasu (1): Remove "werkzeug-test" in RDEPENDS Change-Id: Ideadf7469c094d3f26382af6203403ac5c29c6ee Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/dfu-util')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb7
-rw-r--r--meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util/0001-Revert-Makefile.am-Drop-static-dfu-util.patch68
-rw-r--r--meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util_0.9.bb10
3 files changed, 9 insertions, 76 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb b/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
index aeca23bf2d..76faefefbb 100644
--- a/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
+++ b/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
@@ -4,12 +4,15 @@ inherit native deploy
DEPENDS = "libusb1-native"
-SRC_URI += "file://0001-Revert-Makefile.am-Drop-static-dfu-util.patch"
+PACKAGECONFIG ??= ""
+
+PACKAGECONFIG[static] = "CFLAGS='${CFLAGS} -pthread -static',,"
do_deploy[sstate-outputdirs] = "${DEPLOY_DIR_TOOLS}"
do_deploy() {
- install -m 0755 src/dfu-util_static ${DEPLOYDIR}/dfu-util-${PV}
+ install -m 0755 src/dfu-util ${DEPLOYDIR}/dfu-util-${PV}
rm -f ${DEPLOYDIR}/dfu-util
ln -sf ./dfu-util-${PV} ${DEPLOYDIR}/dfu-util
}
+
addtask deploy before do_package after do_install
diff --git a/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util/0001-Revert-Makefile.am-Drop-static-dfu-util.patch b/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util/0001-Revert-Makefile.am-Drop-static-dfu-util.patch
deleted file mode 100644
index 1c6ad0807e..0000000000
--- a/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util/0001-Revert-Makefile.am-Drop-static-dfu-util.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-From c2aab3b9ae1febcb6b4c6561a59df1930a57b394 Mon Sep 17 00:00:00 2001
-From: Martin JaMa Jansa <Martin.Jansa@gmail.com>
-Date: Thu, 11 Aug 2011 11:19:52 +0200
-Subject: [PATCH] Revert "Makefile.am: Drop static dfu-util"
-
-This reverts commit fe0426ddc04f503d148c5e5f931f16b8f674f071.
-
-Signed-off-by: Martin JaMa Jansa <Martin.Jansa@gmail.com>
----
- configure.ac | 2 +-
- src/Makefile.am | 22 +++++++++++++++++++++-
- 2 files changed, 22 insertions(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index f5a43b8..6a3757e 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -21,7 +21,7 @@ AS_IF([test x$native_libusb = xno], [
- AC_MSG_ERROR([*** Required libusb-1.0 >= 1.0.0 not installed ***]))
- ])
-
--LIBS="$LIBS $USB_LIBS"
-+LIBS="$LIBS $USB_LIBS -lpthread"
- CFLAGS="$CFLAGS $USB_CFLAGS"
-
- # Checks for header files.
-diff --git a/src/Makefile.am b/src/Makefile.am
-index 70179c4..e8736ee 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -1,6 +1,6 @@
- AM_CFLAGS = -Wall -Wextra
-
--bin_PROGRAMS = dfu-util dfu-suffix dfu-prefix
-+bin_PROGRAMS = dfu-util dfu-util_static dfu-suffix dfu-prefix
- dfu_util_SOURCES = main.c \
- portable.h \
- dfu_load.c \
-@@ -19,6 +19,26 @@ dfu_util_SOURCES = main.c \
- quirks.c \
- quirks.h
-
-+dfu_util_static_SOURCES = main.c \
-+ portable.h \
-+ dfu_load.c \
-+ dfu_load.h \
-+ dfu_util.c \
-+ dfu_util.h \
-+ dfuse.c \
-+ dfuse.h \
-+ dfuse_mem.c \
-+ dfuse_mem.h \
-+ dfu.c \
-+ dfu.h \
-+ usb_dfu.h \
-+ dfu_file.c \
-+ dfu_file.h \
-+ quirks.c \
-+ quirks.h
-+
-+dfu_util_static_LDFLAGS = -static
-+
- dfu_suffix_SOURCES = suffix.c \
- dfu_file.h \
- dfu_file.c
---
-2.7.2
-
diff --git a/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util_0.9.bb b/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util_0.9.bb
index 76e1552c0c..8a2ac69347 100644
--- a/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util_0.9.bb
+++ b/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util_0.9.bb
@@ -1,15 +1,13 @@
DESCRIPTION = "USB Device Firmware Upgrade utility"
+AUTHOR = "Harald Welte <laforge@openmoko.org>"
HOMEPAGE = "http://dfu-util.sourceforge.net"
SECTION = "devel"
-AUTHOR = "Harald Welte <laforge@openmoko.org>"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-
-SRC_URI = "http://dfu-util.gnumonks.org/releases/${BP}.tar.gz"
-
-inherit autotools pkgconfig
-
DEPENDS = "libusb1"
+SRC_URI = "http://dfu-util.sourceforge.net/releases/${BP}.tar.gz"
SRC_URI[md5sum] = "233bb1e08ef4b405062445d84e28fde6"
SRC_URI[sha256sum] = "36428c6a6cb3088cad5a3592933385253da5f29f2effa61518ee5991ea38f833"
+
+inherit autotools pkgconfig