summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb
diff options
context:
space:
mode:
authorDave Cobbley <david.j.cobbley@linux.intel.com>2018-08-14 20:05:37 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-23 04:26:31 +0300
commiteb8dc40360f0cfef56fb6947cc817a547d6d9bc6 (patch)
treede291a73dc37168da6370e2cf16c347d1eba9df8 /meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb
parent9c3cf826d853102535ead04cebc2d6023eff3032 (diff)
downloadopenbmc-eb8dc40360f0cfef56fb6947cc817a547d6d9bc6.tar.xz
[Subtree] Removing import-layers directory
As part of the move to subtrees, need to bring all the import layers content to the top level. Change-Id: I4a163d10898cbc6e11c27f776f60e1a470049d8f Signed-off-by: Dave Cobbley <david.j.cobbley@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb b/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb
new file mode 100644
index 0000000000..3a6319c314
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb
@@ -0,0 +1,62 @@
+SUMMARY = "lio-utils"
+DESCRIPTION = "a simple low-level configuration tool set for the Target+iSCSI (LIO)"
+HOMEPAGE = "http://linux-iscsi.org/index.php/Lio-utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://debian/copyright;md5=c3ea231a32635cbb5debedf3e88aa3df"
+
+PV = "4.1+git${SRCPV}"
+
+SRC_URI = "git://risingtidesystems.com/lio-utils.git \
+ file://0001-Makefiles-Respect-environment-variables-and-add-LDFL.patch \
+ "
+SRCREV = "28bd928655bdc7bd3cf380f0196630690c51e05f"
+S = "${WORKDIR}/git"
+
+inherit distutils
+
+EXTRA_OEMAKE += "DESTDIR=${D}"
+
+do_compile() {
+ cd ${S}/tcm-py
+ distutils_do_compile
+
+ cd ${S}/lio-py
+ distutils_do_compile
+
+ if test -d ${S}/tools; then
+ oe_runmake -C ${S}/tools
+ fi
+}
+
+do_install() {
+ cd ${S}/tcm-py
+ distutils_do_install
+
+ cd ${S}/lio-py
+ distutils_do_install
+
+ SITE_PACKAGES=${D}/${PYTHON_SITEPACKAGES_DIR}
+ install -d ${D}/${sbindir}
+ for var in tcm_node tcm_dump tcm_loop tcm_fabric lio_dump lio_node; do
+ if [ ! -h ${D}/${sbindir}/${var} ];then
+ chmod a+x ${SITE_PACKAGES}/${var}.py
+ ln -s ${PYTHON_SITEPACKAGES_DIR}/${var}.py ${D}/${sbindir}/${var}
+ fi
+ done
+
+ if test -d ${S}/tools; then
+ oe_runmake -C ${S}/tools install
+ fi
+
+ install -d ${D}/etc/target/
+ install -d ${D}/etc/init.d/
+ install -m 755 ${S}/scripts/rc.target ${D}/etc/init.d/
+ install -m 755 ${S}/conf/tcm_start.default ${D}/etc/target/tcm_start.sh
+ install -m 755 ${S}/conf/lio_start.default ${D}/etc/target/lio_start.sh
+}
+
+RDEPENDS_${PN} += "python-stringold python-subprocess python-shell \
+ python-datetime python-textutils python-crypt python-netclient python-email \
+ bash"
+
+FILES_${PN} += "${sbindir}/* /etc/init.d/* /etc/target/*"