summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support/uim
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-27 15:23:48 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-27 15:23:52 +0300
commit779d0acafa041a9df8ff46c614778538ab68acbd (patch)
tree39df5c7c2c0040c667131b35e01fa2e674cb78e7 /meta-openembedded/meta-oe/recipes-support/uim
parent9856fce4c853303bacbe5464a24759daeeb34684 (diff)
downloadopenbmc-779d0acafa041a9df8ff46c614778538ab68acbd.tar.xz
meta-openembedded: subtree update:466fd78ac6..41fe46157c
Callaghan, Dan (2): firewalld: add UPSTREAM_CHECK_URI add new recipes for python-lrparsing, python3-lrparsing Khem Raj (2): mongodb: Remove non building arches from COMPATIBLE_HOST uim: Fix cross-builds Martin Jansa (1): libmicrohttpd: backport the fix for building with older gnutls Oleksandr Kravchuk (4): libyui: update to 3.6.0 libyui-ncurses: udpate to 2.52.0 sanlock: update to 3.6.0 tesseract-lang: update to 4.0.0 Randy MacLeod (1): crash: update from 7.2.6 to 7.2.7 Robert Yang (8): python-asn1crypto: extend to nativesdk python-incremental: Drop broken nativesdk fuse: Fix installed-vs-shipped for nativesdk keyutils: Fix installed-vs-shipped for nativesdk libnet-ssleay-perl: Drop broken native libnet-dns-sec-perl: Drop broken native iperf3: Drop broken native spice: Drop broken native Trevor Gamblin (1): haveged: upgrade v1.9.4 -> v1.9.6 Zang Ruochen (5): xterm: upgrade 348 -> 349 python-cmd2: upgrade 0.9.16 -> 0.9.17 python-protobuf: upgrade 3.9.1 -> 3.9.2 python-alembic: upgrade 1.2.0 -> 1.2.1 python-paste: upgrade 3.2.0 -> 3.2.1 Change-Id: I4491ea47f5e54f4f3843a77c720d0a89304c36a5 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support/uim')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/uim/uim/0001-Fix-to-set-libedit-path-from-configure-option-proper.patch29
-rw-r--r--meta-openembedded/meta-oe/recipes-support/uim/uim/0001-fix-bug-for-cross-compile.patch24
-rw-r--r--meta-openembedded/meta-oe/recipes-support/uim/uim_1.8.8.bb10
3 files changed, 36 insertions, 27 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/uim/uim/0001-Fix-to-set-libedit-path-from-configure-option-proper.patch b/meta-openembedded/meta-oe/recipes-support/uim/uim/0001-Fix-to-set-libedit-path-from-configure-option-proper.patch
new file mode 100644
index 0000000000..34a1ea0fa2
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/uim/uim/0001-Fix-to-set-libedit-path-from-configure-option-proper.patch
@@ -0,0 +1,29 @@
+From f828a89cc1e956d56498422ec158d284fc97de3f Mon Sep 17 00:00:00 2001
+From: OBATA Akio <obache@outlook.com>
+Date: Fri, 10 Aug 2018 18:38:18 +0900
+Subject: [PATCH] Fix to set libedit path from configure option properly
+
+Upstream-Status: Backport [https://github.com/uim/uim/pull/134]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 00d1b02..9c0a5ec 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1311,8 +1311,8 @@ if test "x$with_libedit" != xno; then
+ if test "x$with_libedit" = xyes; then
+ libedit_path=/usr
+ else
+- with_libedit=yes
+ libedit_path="$with_libedit"
++ with_libedit=yes
+ fi
+
+ saved_CPPFLAGS=$CPPFLAGS
+--
+2.23.0
+
diff --git a/meta-openembedded/meta-oe/recipes-support/uim/uim/0001-fix-bug-for-cross-compile.patch b/meta-openembedded/meta-oe/recipes-support/uim/uim/0001-fix-bug-for-cross-compile.patch
deleted file mode 100644
index 510a8c8407..0000000000
--- a/meta-openembedded/meta-oe/recipes-support/uim/uim/0001-fix-bug-for-cross-compile.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 08b5e51224ed95b1e76e99873b5f9f59840b0a74 Mon Sep 17 00:00:00 2001
-From: Lei Maohui <leimaohui@cn.fujitsu.com>
-Date: Fri, 21 Aug 2015 15:58:42 +0900
-Subject: [PATCH] fix bug for cross compile
-
-Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com>
-
----
- configure.ac | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -1317,8 +1317,8 @@ if test "x$with_libedit" != xno; then
-
- saved_CPPFLAGS=$CPPFLAGS
- saved_LDFLAGS=$LDFLAGS
-- CPPFLAGS="${CPPFLAGS} -I$libedit_path/include"
-- LDFLAGS="${LDFLAGS} -L$libedit_path/lib"
-+ CPPFLAGS="${CPPFLAGS}"
-+ LDFLAGS="${LDFLAGS}"
- AC_CHECK_LIB(curses, tgetent, LIBEDIT_LIBS="-lcurses",
- [AC_CHECK_LIB(ncurses, tgetent, LIBEDIT_LIBS="-lncurses",
- AC_MSG_WARN("libedit needs libcurses or libncurses. disabled...")
diff --git a/meta-openembedded/meta-oe/recipes-support/uim/uim_1.8.8.bb b/meta-openembedded/meta-oe/recipes-support/uim/uim_1.8.8.bb
index cc28e6e8fd..8948ebf30f 100644
--- a/meta-openembedded/meta-oe/recipes-support/uim/uim_1.8.8.bb
+++ b/meta-openembedded/meta-oe/recipes-support/uim/uim_1.8.8.bb
@@ -4,11 +4,11 @@ LICENSE = "BSD-3-Clause & LGPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=ab2826b41ca0ff4030d38cc39791d1c8"
SECTION = "inputmethods"
-SRC_URI = "https://github.com/uim/uim/releases/download/${PV}/uim-${PV}.tar.bz2"
-
+SRC_URI = "https://github.com/uim/uim/releases/download/${PV}/uim-${PV}.tar.bz2 \
+ file://0001-Fix-to-set-libedit-path-from-configure-option-proper.patch \
+"
SRC_URI_append_class-target = "\
file://uim-module-manager.patch \
- file://0001-fix-bug-for-cross-compile.patch \
"
SRC_URI[md5sum] = "01c7bd5d0d4f3a9f6f5befe6f57a470b"
SRC_URI[sha256sum] = "34599bbcc4e5ab87832370763e38be5100984a64237555e9234a1ea225a0fadc"
@@ -22,6 +22,9 @@ RDEPENDS_uim-anthy_append_libc-glibc = " glibc-utils glibc-gconv-euc-jp"
LEAD_SONAME = "libuim.so.1"
+COMPATIBLE_HOST_riscv64 = "null"
+COMPATIBLE_HOST_riscv32 = "null"
+
inherit distro_features_check autotools pkgconfig gettext qemu gtk-immodules-cache
REQUIRED_DISTRO_FEATURES = "x11"
@@ -29,6 +32,7 @@ REQUIRED_DISTRO_FEATURES = "x11"
GTKIMMODULES_PACKAGES = "uim-gtk2.0 uim-gtk3"
EXTRA_OECONF += "--disable-emacs \
+ --with-libedit=${STAGING_EXECPREFIXDIR} \
--without-scim \
--without-m17nlib \
--without-prime \