summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-support
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-10 14:20:03 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-10 14:20:04 +0300
commit5f78ea18ab7503162e715c306f55312f154d3705 (patch)
tree2388490d970f10299cb1f84772438c6c6a8dafd2 /meta-openembedded/meta-oe/recipes-support
parentea52c6b623935aab36bcc5fb59638541c314defc (diff)
downloadopenbmc-5f78ea18ab7503162e715c306f55312f154d3705.tar.xz
meta-openembedded: subtree update:3061ead8cf..ce51958eca
Adrian Bunk (1): librcf: Remove, PNBLACKLIST since April 2018 Khem Raj (3): openocd: disable werror when building with gcc kernel-selftest: Needs error.h which is missing in musl remmina: Add space before append operation Zheng Ruoqin (2): python-prettytable: Add python3 version python3-colorama: New recipe aehs29@gmail.com (1): remmina: Fix spice protocol dependency and configuration Change-Id: Ia4674cf3ab186b06c25f0601e02ddc00c96b781f Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-support')
-rw-r--r--meta-openembedded/meta-oe/recipes-support/remmina/remmina_1.3.6.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/meta-openembedded/meta-oe/recipes-support/remmina/remmina_1.3.6.bb b/meta-openembedded/meta-oe/recipes-support/remmina/remmina_1.3.6.bb
index b95c400b28..126680c574 100644
--- a/meta-openembedded/meta-oe/recipes-support/remmina/remmina_1.3.6.bb
+++ b/meta-openembedded/meta-oe/recipes-support/remmina/remmina_1.3.6.bb
@@ -3,9 +3,12 @@ HOMEPAGE = "https://remmina.org"
SECTION = "Support"
LICENSE = "GPLv2 & openssl"
LIC_FILES_CHKSUM = "file://LICENSE;md5=dab7215512044d49037272ce1ac4ea8f file://LICENSE.OpenSSL;md5=c1eb3cee0a4dea27503c531267a69769"
-DEPENDS += "openssl freerdp gtk+3 gdk-pixbuf atk libgcrypt avahi-ui libsodium libssh vte json-glib libsoup-2.4 libvncserver spice spice-protocol libsecret"
+DEPENDS += "openssl freerdp gtk+3 gdk-pixbuf atk libgcrypt avahi-ui libsodium libssh vte json-glib libsoup-2.4 libvncserver libsecret"
-DEPENDS_append_libc-musl = "libexecinfo"
+DEPENDS_append_x86 = " spice spice-protocol"
+DEPENDS_append_x86-64 = " spice spice-protocol"
+
+DEPENDS_append_libc-musl = " libexecinfo"
LDFLAGS_append_libc-musl = " -lexecinfo"
SRC_URI = "https://gitlab.com/Remmina/Remmina/-/archive/v${PV}/Remmina-v${PV}.tar.bz2 \
@@ -17,7 +20,11 @@ S = "${WORKDIR}/Remmina-v${PV}"
inherit cmake
-EXTRA_OECMAKE += "-DWITH_APPINDICATOR=OFF -DWITH_GETTEXT=OFF -DWITH_TRANSLATIONS=OFF"
+EXTRA_OECMAKE += "-DWITH_APPINDICATOR=OFF -DWITH_GETTEXT=OFF -DWITH_TRANSLATIONS=OFF -DWITH_SPICE=OFF"
+
+EXTRA_OECMAKE_append_x86 = " -DWITH_SPICE=ON"
+EXTRA_OECMAKE_append_x86-64 = " -DWITH_SPICE=ON"
+
do_install_append(){
# We dont need the extra stuff form other desktop environments
@@ -29,5 +36,3 @@ do_install_append(){
RDEPENDS_${PN} = "bash"
FILES_${PN}_append = " ${datadir}/icons/hicolor/*"
-
-COMPATIBLE_HOST = '(x86_64|i.86).*-linux'