summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-test
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-16 14:44:26 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-16 14:44:31 +0300
commit7e36d53b0e80af58191fd2680577e6d766af55c7 (patch)
tree44d45604599adc5b9d025802e6a3b527a34f9325 /meta-openembedded/meta-oe/recipes-test
parent7ec1d679d1961f22e47bcec8d7e79101edd6a131 (diff)
downloadopenbmc-7e36d53b0e80af58191fd2680577e6d766af55c7.tar.xz
meta-openembedded: subtree update:a2928764c2..19528ba2a6
Adrian Bunk (1): libqmi: Replace clang patch with configure option Bartosz Golaszewski (3): yad: new package zenity: new package unclutter-xfixes: new package Khem Raj (2): mycroft: Remove alsa-oss from rdeps bigbuckbunny: Use faster download mirrors Oleksandr Kravchuk (21): capnproto: update to 0.7.0 ddrescue: update to 1.24 fmt: update to 6.0.0 jsonrpc: update to 1.2.0 libburn: update to 1.5.0 libdvdread: update to 6.0.1 libev: update to 4.27 libmodplug: update to 0.8.9.0 libnice: update to 0.1.16 libopus: update to 1.3.1 libsass: update to 3.6.1 libuv: update to 1.32.0 libsocketcan: update to 0.0.11 tree: update to 1.8.0 xclock: update to 1.0.9 xcursorgen: update to 1.0.7 xfontsel: update to 1.0.6 xmag: update to 1.0.6 xmessage: update to 1.0.5 xorg-sgml-doctools: update to 1.11 evtest: update to 1.34 Peiran Hong (1): tcpdump: Fix CVE-2017-16808 Change-Id: I4f2f575382cd34404d10470ece0aae7620487902 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-test')
-rw-r--r--meta-openembedded/meta-oe/recipes-test/evtest/evtest/add_missing_limits_h_include.patch37
-rw-r--r--meta-openembedded/meta-oe/recipes-test/evtest/evtest_1.34.bb (renamed from meta-openembedded/meta-oe/recipes-test/evtest/evtest_git.bb)7
2 files changed, 40 insertions, 4 deletions
diff --git a/meta-openembedded/meta-oe/recipes-test/evtest/evtest/add_missing_limits_h_include.patch b/meta-openembedded/meta-oe/recipes-test/evtest/evtest/add_missing_limits_h_include.patch
new file mode 100644
index 0000000000..b2bf94fd56
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-test/evtest/evtest/add_missing_limits_h_include.patch
@@ -0,0 +1,37 @@
+From 5eb4ab1c139ea38ebe6bb4acba08b09ee7d77d3c Mon Sep 17 00:00:00 2001
+From: Baruch Siach <baruch@tkos.co.il>
+Date: Sun, 18 Aug 2019 10:01:06 +0300
+Subject: Add missing limits.h include
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Fixes build with musl libc that does not include limits.h indirectly via
+other headers.
+
+evtest.c: In function ‘scan_devices’:
+evtest.c:886:14: error: ‘PATH_MAX’ undeclared (first use in this function); did you mean INT8_MAX’?
+ char fname[PATH_MAX];
+ ^~~~~~~~
+
+Signed-off-by: Baruch Siach <baruch@tkos.co.il>
+Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
+---
+ evtest.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/evtest.c b/evtest.c
+index 37d4f85..548c203 100644
+--- a/evtest.c
++++ b/evtest.c
+@@ -56,6 +56,7 @@
+ #include <getopt.h>
+ #include <ctype.h>
+ #include <signal.h>
++#include <limits.h>
+ #include <sys/time.h>
+ #include <sys/types.h>
+ #include <unistd.h>
+--
+cgit v1.1
+
diff --git a/meta-openembedded/meta-oe/recipes-test/evtest/evtest_git.bb b/meta-openembedded/meta-oe/recipes-test/evtest/evtest_1.34.bb
index fa0d6e2fe5..3b6dc61408 100644
--- a/meta-openembedded/meta-oe/recipes-test/evtest/evtest_git.bb
+++ b/meta-openembedded/meta-oe/recipes-test/evtest/evtest_1.34.bb
@@ -7,10 +7,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
DEPENDS = "libxml2"
-SRCREV = "ab140a2dab1547f7deb5233be6d94a388cf08b26"
-SRC_URI = "git://anongit.freedesktop.org/evtest;protocol=git"
-
-PV = "1.33+${SRCPV}"
+SRCREV = "16e5104127a620686bdddc4a9ad62881134d6c69"
+SRC_URI = "git://anongit.freedesktop.org/evtest;protocol=git \
+ file://add_missing_limits_h_include.patch"
S = "${WORKDIR}/git"