summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 13:30:50 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-05 00:28:29 +0300
commitd3f78932cf6b3063caceacdae9ddd6ca30d48786 (patch)
tree765de745d26798d7a37340d2851b86b57cda7eb8 /meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.bb
parentf1ade61b5994799a4cffca0c124b2ed36e640cbf (diff)
downloadopenbmc-d3f78932cf6b3063caceacdae9ddd6ca30d48786.tar.xz
meta-openpower: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-openpower is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-openpower rev: 2c8db5661cecd7e4cc20bcb96df76490e62cfb67) Change-Id: I415caaa28ec728f24e755ddb549012f24874fefe Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.bb')
-rw-r--r--meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.bb b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.bb
new file mode 100644
index 0000000000..118c1c2b0e
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
+DESCRIPTION = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
+PR = "r1"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-license
+inherit obmc-phosphor-ipmiprovider-symlink
+inherit pythonnative
+
+require ${PN}.inc
+
+DEPENDS += "phosphor-ipmi-host"
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbusplus sdbusplus-native"
+DEPENDS += "phosphor-logging"
+DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
+DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
+DEPENDS += "sdbus++-native"
+
+RDEPENDS_${PN} += " \
+ sdbusplus \
+ phosphor-logging \
+ openpower-dbus-interfaces \
+ phosphor-dbus-interfaces \
+ "
+
+TARGET_CFLAGS += "-fpic"
+
+HOSTIPMI_PROVIDER_LIBRARY += "liboemhandler.so"
+
+S = "${WORKDIR}/git"
+
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"