summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-example-native.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 13:30:50 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-05 00:28:29 +0300
commitd3f78932cf6b3063caceacdae9ddd6ca30d48786 (patch)
tree765de745d26798d7a37340d2851b86b57cda7eb8 /meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-example-native.bb
parentf1ade61b5994799a4cffca0c124b2ed36e640cbf (diff)
downloadopenbmc-d3f78932cf6b3063caceacdae9ddd6ca30d48786.tar.xz
meta-openpower: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-openpower is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-openpower rev: 2c8db5661cecd7e4cc20bcb96df76490e62cfb67) Change-Id: I415caaa28ec728f24e755ddb549012f24874fefe Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-example-native.bb')
-rw-r--r--meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-example-native.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-example-native.bb b/meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-example-native.bb
new file mode 100644
index 0000000000..72b82a0b3b
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-example-native.bb
@@ -0,0 +1,17 @@
+SUMMARY = "OpenPower OCC Control with example occ sensor IDs"
+PR = "r1"
+
+inherit native
+require openpower-occ-control.inc
+inherit openpower-occ-control
+
+PROVIDES += "virtual/openpower-occ-control-config-native"
+
+S = "${WORKDIR}/git"
+
+# Copies example occ sensor ID yaml file
+do_install() {
+ SRC=${S}
+ install -d ${YAML_DEST}/
+ install -D ${SRC}/example/occ_sensor.yaml ${YAML_DEST}/occ_sensor.yaml
+}