summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-02-18 00:11:03 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-03-16 18:50:35 +0300
commit82cfa666a8eaea5cd8f0bca9a13113ad8b949190 (patch)
tree3b1b06a5a57e458e527031768f3c2e4818b16c6a /meta-openpower
parent0989ba28bbe71cb62f6859b7493e193696835221 (diff)
downloadopenbmc-82cfa666a8eaea5cd8f0bca9a13113ad8b949190.tar.xz
warm-reboot: stop instr and cfam reset
Install the new stop instructions and cfam reset services required for a warm reboot into the appropriate target Includes following in bump: Andrew Geissler (4): warm-reboot: ensure sbe start bit is 0 warm reboot: stop instructions support warm-reboot: add cfam-reset capabilities warm-reboot: cfam-reset service (From meta-openpower rev: 84962a9850f8f7b61698134ecf2d016a9b1e33de) Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: Ia8fe30f160e0078bbdca2bcef322c9e23ea0e9e0 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb32
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb4
-rw-r--r--meta-openpower/recipes-phosphor/host/p9-host-start.bb4
3 files changed, 38 insertions, 2 deletions
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
new file mode 100644
index 0000000000..cd4f63baec
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -0,0 +1,32 @@
+SUMMARY = "OpenPOWER processor control services installation"
+PR = "r1"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit allarch
+
+RDEPENDS_${PN} += "op-proc-control"
+RDEPENDS_${PN} += "phosphor-state-manager-obmc-targets"
+
+ALLOW_EMPTY_${PN} = "1"
+
+pkg_postinst_${PN}() {
+ mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.requires
+ mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires
+
+ LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.requires/op-stop-instructions@0.service"
+ TARGET="../op-stop-instructions@.service"
+ ln -s $TARGET $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/op-cfam-reset.service"
+ TARGET="../op-cfam-reset.service"
+ ln -s $TARGET $LINK
+}
+
+pkg_prerm_${PN}() {
+ LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.requires/op-stop-instructions@0.service"
+ rm $LINK
+ LINK="$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/op-cfam-reset.service"
+ rm $LINK
+}
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index 1e6aa03352..7d38be4d25 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -11,7 +11,7 @@ inherit autotools obmc-phosphor-utils pkgconfig pythonnative
inherit systemd
SRC_URI += "git://github.com/openbmc/openpower-proc-control"
-SRCREV = "a5311abddaa057a50b492c839b310f968a7e270f"
+SRCREV = "a007668ac9a4c0cf0ca4bd50f86159822341c3cc"
DEPENDS += " \
autoconf-archive-native \
@@ -31,4 +31,6 @@ SYSTEMD_SERVICE_${PN} = "${TEMPLATE} ${INSTANCES}"
SYSTEMD_SERVICE_${PN} += " \
xyz.openbmc_project.Control.Host.NMI.service \
+ op-stop-instructions@.service \
+ op-cfam-reset.service \
"
diff --git a/meta-openpower/recipes-phosphor/host/p9-host-start.bb b/meta-openpower/recipes-phosphor/host/p9-host-start.bb
index 374359838d..6905f34aa5 100644
--- a/meta-openpower/recipes-phosphor/host/p9-host-start.bb
+++ b/meta-openpower/recipes-phosphor/host/p9-host-start.bb
@@ -11,7 +11,9 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/op-host-control:"
PROVIDES += 'virtual/obmc-host-ctl'
RPROVIDES_${PN} += 'virtual-obmc-host-ctl'
-RDEPENDS_${PN} += "p9-vcs-workaround op-proc-control"
+RDEPENDS_${PN} += "p9-vcs-workaround \
+ op-proc-control \
+ op-proc-control-systemd-links"
S = "${WORKDIR}"