summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2022-02-17 16:30:57 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-02-18 21:41:12 +0300
commitd5c716dc3add128301ec4ba8ebb21bb6eb7856fd (patch)
treeec3dcdc3ab942a2beac6b9207f3a8506bfaa34af /meta-openpower
parent18a6b18c34b9c651b96fa3fb5be956aee1604db9 (diff)
downloadopenbmc-d5c716dc3add128301ec4ba8ebb21bb6eb7856fd.tar.xz
treewide: fix append/remove directives
As mentioned by I970e06ca6f9d0a9792af122eb25da1bb9a06f058, append and remove directives with '+=' are no longer valid Yocto syntax and raise a warning. See https://git.yoctoproject.org/poky/tree/documentation/migration-guides/migration-3.5.rst#n40 One interesting caveat has to do with the difference between "append" and "+=". foo:append = "a" foo:append = "b" Results in `foo = "ab"`, but foo += "a" foo += "b" Results in `foo = "a b"`. When `:append +=` is used it has behavior like the `+=` operator. Therefore, in some cases we need to insert additional whitespace after the `:append = "` to ensure concatenation behaves as expected. I've manually reviewed the results to ensure there is no ill side-effects from an additional space potentially being added. Fix up the entire tree with the following one-liner (and similar for `remove`): git ls-files -- ':!:poky/**' ':!:meta-security/**' \ ':!:meta-raspberrypi/**' ':!:meta-openembedded/**' \ | grep "\.bb" | xargs grep -l ":append.*+=" \ | xargs sed -i 's/:append\(.*\)+=\([^"]*\)" */:append\1=\2" /' or ... | xargs grep -l ":remove.*+=" \ | xargs sed -i "s/:remove\(.*\)+=/:remove\1=/" Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Iea6235e7c76e252f4d473652957c2925f6b8845a
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
index 804084e1dc..c39c077867 100644
--- a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
+++ b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
@@ -77,7 +77,7 @@ DEPENDS:remove:class-native = " \
sdbusplus \
virtual/${PN}-config-native \
"
-RDEPENDS:${PN}:remove:class-native += "phosphor-state-manager-obmc-targets"
+RDEPENDS:${PN}:remove:class-native = "phosphor-state-manager-obmc-targets"
# Remove packages not required for native SDK build
DEPENDS:remove:class-nativesdk = " \
@@ -86,7 +86,7 @@ DEPENDS:remove:class-nativesdk = " \
sdbusplus \
virtual/${PN}-config-native \
"
-RDEPENDS:${PN}:remove:class-nativesdk += "phosphor-state-manager-obmc-targets"
+RDEPENDS:${PN}:remove:class-nativesdk = "phosphor-state-manager-obmc-targets"
# Provide a means to enable/disable install_error_yaml feature
PACKAGECONFIG ??= "install_error_yaml"