summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
authorJayanth Othayoth <ojayanth@in.ibm.com>2020-02-12 13:16:53 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-21 19:46:12 +0300
commit389a7046dffd70ef9ce1a5b0a7f5be3371c646a2 (patch)
treecd1d46b9c5c8396eac19e8a46341524e969d5cc2 /meta-openpower
parentf95063e21a8db116ccb1eb13dc5afcd82383dd04 (diff)
downloadopenbmc-389a7046dffd70ef9ce1a5b0a7f5be3371c646a2.tar.xz
openpower: Remove VCS workaround service
This was a P9 DD1 workaround. These systems are no longer supported and are not found in the wild, so the workaround has been retired. Most (all?) platforms in the tree opted out of this package by using RDEPENDS_${PN}_remove_, so this should be a noop. (From meta-openpower rev: 1db2de4c16aa9644462c182c4f525604d3a8e945) Change-Id: I62f3b21768aae1cc05d2f28799868f028ebb2733 Signed-off-by: Jayanth Othayoth <ojayanth@in.ibm.com> Signed-off-by: Joel Stanley <joel@jms.id.au> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/conf/machine/include/p9.inc2
-rw-r--r--meta-openpower/recipes-phosphor/host/op-host-control/vcs_workaround@.service19
-rw-r--r--meta-openpower/recipes-phosphor/host/p9-host-start.bb3
-rw-r--r--meta-openpower/recipes-phosphor/host/p9-vcs-workaround.bb20
4 files changed, 2 insertions, 42 deletions
diff --git a/meta-openpower/conf/machine/include/p9.inc b/meta-openpower/conf/machine/include/p9.inc
index b0e0bb95ee..4c30aac185 100644
--- a/meta-openpower/conf/machine/include/p9.inc
+++ b/meta-openpower/conf/machine/include/p9.inc
@@ -1,2 +1,2 @@
-OBMC_MACHINE_FEATURES += 'p9-vcs-workaround op-fsi p9-cfam-override'
+OBMC_MACHINE_FEATURES += 'op-fsi p9-cfam-override'
PREFERRED_PROVIDER_virtual/obmc-host-ctl = "p9-host-start"
diff --git a/meta-openpower/recipes-phosphor/host/op-host-control/vcs_workaround@.service b/meta-openpower/recipes-phosphor/host/op-host-control/vcs_workaround@.service
deleted file mode 100644
index bd9db809bf..0000000000
--- a/meta-openpower/recipes-phosphor/host/op-host-control/vcs_workaround@.service
+++ /dev/null
@@ -1,19 +0,0 @@
-[Unit]
-Description=Run VCS workaround on host%i
-Wants=obmc-host-start-pre@%i.target
-Before=obmc-host-start-pre@%i.target
-Wants=obmc-power-on@%i.target
-After=obmc-power-on@%i.target
-Wants=fsi-scan@%i.service
-After=fsi-scan@%i.service
-Conflicts=obmc-chassis-poweroff@%i.target
-ConditionPathExists=!/run/openbmc/chassis@%i-on
-
-[Service]
-ExecStart=/usr/bin/env openpower-proc-control vcsWorkaround
-SyslogIdentifier=openpower-proc-control
-Type=oneshot
-RemainAfterExit=yes
-
-[Install]
-WantedBy=obmc-chassis-poweron@%i.target
diff --git a/meta-openpower/recipes-phosphor/host/p9-host-start.bb b/meta-openpower/recipes-phosphor/host/p9-host-start.bb
index 6905f34aa5..84dc7b14af 100644
--- a/meta-openpower/recipes-phosphor/host/p9-host-start.bb
+++ b/meta-openpower/recipes-phosphor/host/p9-host-start.bb
@@ -11,8 +11,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/op-host-control:"
PROVIDES += 'virtual/obmc-host-ctl'
RPROVIDES_${PN} += 'virtual-obmc-host-ctl'
-RDEPENDS_${PN} += "p9-vcs-workaround \
- op-proc-control \
+RDEPENDS_${PN} += "op-proc-control \
op-proc-control-systemd-links"
S = "${WORKDIR}"
diff --git a/meta-openpower/recipes-phosphor/host/p9-vcs-workaround.bb b/meta-openpower/recipes-phosphor/host/p9-vcs-workaround.bb
deleted file mode 100644
index 29167b0e1c..0000000000
--- a/meta-openpower/recipes-phosphor/host/p9-vcs-workaround.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-SUMMARY = "POWER9 VCS workaround"
-DESCRIPTION = "Apply fixes over FSI to POWER9 CPUs prior to host power on"
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit obmc-phosphor-systemd
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/op-host-control:"
-RDEPENDS_${PN} += "virtual-p9-vcs-workaround op-proc-control"
-
-S = "${WORKDIR}"
-
-TMPL = "vcs_workaround@.service"
-INSTFMT = "vcs_workaround@{0}.service"
-TGTFMT = "obmc-chassis-poweron@{0}.target"
-FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
-
-SYSTEMD_SERVICE_${PN} += "${TMPL}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"