summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
authorRamesh Iyyar <rameshi1@in.ibm.com>2022-02-24 12:35:40 +0300
committerRamesh Iyyar <rameshi1@in.ibm.com>2022-02-24 19:18:44 +0300
commitd0aedb96eaece5ce6164a8133f00c771bdd60e53 (patch)
tree8d82fafa3638299c6df2453f4d98c73fee44d342 /meta-openpower
parent0be85ce19889def150c186e86f6d578ceb9a40af (diff)
downloadopenbmc-d0aedb96eaece5ce6164a8133f00c771bdd60e53.tar.xz
meta-openpower: host: Bumped bbb5339..482a887
In this patch, bumped the openpower-proc-control with the below patches and add the systemd symlinks for the newly added service that included as part of the bump. SRCREV: bbb5339..482a887 - Ramesh Iyyar (1): PHAL: Add new service file to indicate guard actions. Signed-off-by: Ramesh Iyyar <rameshi1@in.ibm.com> Change-Id: Iee1c68636d7084d54b65840c9964981dda395e7f
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb12
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb3
2 files changed, 14 insertions, 1 deletions
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index f3c63adad3..a9c329a216 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -71,6 +71,13 @@ pkg_postinst:${PN}() {
LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/phal-export-devtree@0.service"
TARGET="../phal-export-devtree@.service"
ln -s $TARGET $LINK
+
+ mkdir -p $D$systemd_system_unitdir/obmc-host-start@0.target.wants
+ LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.wants/phal-create-boottime-guard-indicator.service"
+ TARGET="../phal-create-boottime-guard-indicator.service"
+ ln -s $TARGET $LINK
+ LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/phal-create-boottime-guard-indicator.service"
+ ln -s $TARGET $LINK
fi
# If the memory preserving reboot feature is enabled, set it up
@@ -127,6 +134,11 @@ pkg_prerm:${PN}() {
LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/phal-export-devtree@0.service"
rm $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.wants/phal-create-boottime-guard-indicator.service"
+ rm $LINK
+ LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/phal-create-boottime-guard-indicator.service"
+ rm $LINK
fi
# Remove mpreboot specific units if enabled
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index fad514fc41..e245507b11 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -11,7 +11,7 @@ inherit meson obmc-phosphor-utils pkgconfig
inherit systemd
SRC_URI += "git://github.com/openbmc/openpower-proc-control;branch=master;protocol=https"
-SRCREV = "bbb53393c5e2eb2ad4d3ef8401f8481732b84ed0"
+SRCREV = "482a887804fe61a1868000bd2d1b18cacff77533"
DEPENDS += " \
phosphor-logging \
@@ -43,4 +43,5 @@ SYSTEMD_SERVICE:${PN} += " \
${@bb.utils.contains('MACHINE_FEATURES', 'phal', 'phal-reinit-devtree.service', '', d)} \
${@bb.utils.contains('MACHINE_FEATURES', 'phal', 'proc-pre-poweroff@.service', '', d)} \
${@bb.utils.contains('MACHINE_FEATURES', 'phal', 'set-spi-mux.service', '', d)} \
+ ${@bb.utils.contains('MACHINE_FEATURES', 'phal', 'phal-create-boottime-guard-indicator.service', '', d)} \
"