summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
authorMarri Devender Rao <devenrao@in.ibm.com>2022-04-08 16:54:38 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-04-14 20:14:19 +0300
commitce928aca31ddca02435faeb06887ad56cc5217d0 (patch)
treeb803a65b61305646b2b6e05b9e90664fe2ec34f7 /meta-openpower
parente103db6680b25001007bbd85749f5570a97054d8 (diff)
downloadopenbmc-ce928aca31ddca02435faeb06887ad56cc5217d0.tar.xz
dump: move dump plugins to repository but install from recipe.
1) Move ibm specific plugins from recipe to tools/dreport.d/ibm.d/plugins.d in the repository 2) Move openpower specific plugins from recipe to tools/dreport/opepower.d/plugins.d in the repository. 4) Modified to install the plugins from the machine specific plugin folder from the repository Reference links https://gerrit.openbmc-project.xyz/c/openbmc/phosphor-debug-collector/+/52852/ https://gerrit.openbmc-project.xyz/c/openbmc/phosphor-debug-collector/+/52479 Includes: phosphor-debug-collector: srcrev bump 02634e5531..124d31f09c Marri Devender Rao (3): openpower:dreport: add guarded resolved and ephemeral records to BMC dump ibm:dreport add vpd persistent data to BMC dump dreport: Fix network and timedate plugin failures during BMC dump generation Signed-off-by: Marri Devender Rao <devenrao@in.ibm.com> Change-Id: I0bd350b9b564c4e98a6765902de76274f90500e4
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/recipes-phosphor/dump/phosphor-debug-collector/plugins.d/guard18
-rw-r--r--meta-openpower/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend14
2 files changed, 8 insertions, 24 deletions
diff --git a/meta-openpower/recipes-phosphor/dump/phosphor-debug-collector/plugins.d/guard b/meta-openpower/recipes-phosphor/dump/phosphor-debug-collector/plugins.d/guard
deleted file mode 100644
index cdd461fec9..0000000000
--- a/meta-openpower/recipes-phosphor/dump/phosphor-debug-collector/plugins.d/guard
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/bash
-#
-# config: 2 40
-# @brief: Collect GUARD record information.
-#
-
-. $DREPORT_INCLUDE/functions
-
-desc="GUARD Records"
-file_name="/var/lib/phosphor-software-manager/pnor/prsv/GUARD"
-
-# Check file is present and not empty.
-if [ ! -s "$file_name" ]; then
- log_info "No $desc"
- exit 0
-fi
-
-add_copy_file "$file_name" "$desc"
diff --git a/meta-openpower/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend b/meta-openpower/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
index 00b9eadfc6..3f505c3f67 100644
--- a/meta-openpower/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
+++ b/meta-openpower/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
@@ -1,15 +1,17 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-SRC_URI += "file://plugins.d/guard"
install_openpower_plugins() {
- install -m 0755 ${WORKDIR}/plugins.d/guard ${D}${dreport_plugin_dir}
+ install ${S}/tools/dreport.d/openpower.d/plugins.d/* ${D}${dreport_plugin_dir}
}
-#Link in the plugins so dreport run them at the appropriate time
+#Link the plugins so that dreport can run them based on dump type
python link_openpower_plugins() {
- workdir = d.getVar('WORKDIR', True)
- script = os.path.join(workdir, 'plugins.d', 'guard')
- install_dreport_user_script(script, d)
+ source = d.getVar('S', True)
+ source_path = os.path.join(source, "tools", "dreport.d", "openpower.d", "plugins.d")
+ op_plugins = os.listdir(source_path)
+ for op_plugin in op_plugins:
+ op_plugin_name = os.path.join(source_path, op_plugin)
+ install_dreport_user_script(op_plugin_name, d)
}
DEBUG_COLLECTOR_INSTALL_POSTFUNCS ?= ""