summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
authorRamesh Iyyar <rameshi1@in.ibm.com>2020-09-17 18:02:08 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-09-23 01:24:46 +0300
commitd6d9b540f1a98b7f6a7673772216a1fc8db56901 (patch)
treebcc92692fe088bf172ad7977cbbd8875bc7958a5 /meta-openpower
parent1c8460cd2311db9a6470e4b055905a030f59a5a1 (diff)
downloadopenbmc-d6d9b540f1a98b7f6a7673772216a1fc8db56901.tar.xz
phal: Enabled service to reinit CEC device tree
The POWER CEC system device tree need reinitialize before doing normal ipl to mark required targets as functional for ipling. The service file is added in below patch. https://gerrit.openbmc-project.xyz/c/openbmc/openpower-proc-control/+/36577 (From meta-openpower rev: 2257014de9964f673b4ae2864deffd25e6022cee) Signed-off-by: Ramesh Iyyar <rameshi1@in.ibm.com> Change-Id: I499ee3c6c2b4f3caf33609ca6e70112801d5cbae Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb14
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb3
2 files changed, 16 insertions, 1 deletions
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index 9cb75f33e1..521ff02b98 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -45,6 +45,14 @@ pkg_postinst_${PN}() {
LINK="$D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires/op-enter-mpreboot@0.service"
TARGET="../op-enter-mpreboot@.service"
ln -s $TARGET $LINK
+
+ # Only install phal reinit service if phal enabled
+ if [ "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}" = phal ]; then
+ mkdir -p $D$systemd_system_unitdir/obmc-host-start@0.target.requires
+ LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service"
+ TARGET="../phal-reinit-devtree.service"
+ ln -s $TARGET $LINK
+ fi
}
pkg_prerm_${PN}() {
@@ -63,4 +71,10 @@ pkg_prerm_${PN}() {
rm $LINK
LINK="$D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires/op-enter-mpreboot@0.service"
rm $LINK
+
+ # Only phal reinit service if phal enabled
+ if [ "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}" = phal ]; then
+ LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service"
+ rm $LINK
+ fi
}
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index f197c3929f..1ca607b2c8 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -11,7 +11,7 @@ inherit autotools obmc-phosphor-utils pkgconfig
inherit systemd
SRC_URI += "git://github.com/openbmc/openpower-proc-control"
-SRCREV = "e62ca93360e34b4e59ab57b0c0b46221dec61cab"
+SRCREV = "b20593f88b7cb88844363f8475669dad16e88afb"
DEPENDS += " \
autoconf-archive-native \
@@ -36,4 +36,5 @@ SYSTEMD_SERVICE_${PN} += " \
${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'set-spi-mux.service', '', d)} \
op-continue-mpreboot@.service \
op-enter-mpreboot@.service \
+ ${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'phal-reinit-devtree.service', '', d)} \
"