summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2023-04-14 19:24:47 +0300
committerPatrick Williams <patrick@stwcx.xyz>2023-04-17 17:51:12 +0300
commitbccaff3439442ca820760c90da4a2308d3d61b0e (patch)
tree8c190c31e50a28f79d588cc49e101ddafb7b4a28 /meta-openpower
parent65682ac6176742b7d81b64c71d7a37913a39470b (diff)
downloadopenbmc-bccaff3439442ca820760c90da4a2308d3d61b0e.tar.xz
treewide: reduce append operators on SRC_URI
In a base bb file where we are setting the primary git repository, it is rare that we need to `SRC_URI +=`. This is an unnecessary pattern that seems to have been copied throughout the repository. Remove the pattern where appropriate and simply set SRC_URI directly. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I430186a82f9582ba6196f5bf66b659af4092b48d
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/recipes-bsp/ffs/ffs_git.bb2
-rw-r--r--meta-openpower/recipes-bsp/fsidbg/fsidbg_git.bb2
-rw-r--r--meta-openpower/recipes-bsp/pdbg/pdbg_3.6.bb2
-rw-r--r--meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb2
-rw-r--r--meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb2
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb2
-rw-r--r--meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb2
-rw-r--r--meta-openpower/recipes-phosphor/logging/python3-sbe-log-parsers_git.bb2
8 files changed, 8 insertions, 8 deletions
diff --git a/meta-openpower/recipes-bsp/ffs/ffs_git.bb b/meta-openpower/recipes-bsp/ffs/ffs_git.bb
index 0b40db0f46..fed5bf724c 100644
--- a/meta-openpower/recipes-bsp/ffs/ffs_git.bb
+++ b/meta-openpower/recipes-bsp/ffs/ffs_git.bb
@@ -3,6 +3,6 @@ require ffs.inc
PV = "v0.1.0+git${SRCPV}"
SRCREV = "3ec70fbc458e32eef0d0b1de79688b4dc48cbd57"
-SRC_URI += "git://github.com/open-power/ffs.git;branch=master;protocol=https"
+SRC_URI = "git://github.com/open-power/ffs.git;branch=master;protocol=https"
S = "${WORKDIR}/git"
diff --git a/meta-openpower/recipes-bsp/fsidbg/fsidbg_git.bb b/meta-openpower/recipes-bsp/fsidbg/fsidbg_git.bb
index b652ad5592..4a38ba4da4 100644
--- a/meta-openpower/recipes-bsp/fsidbg/fsidbg_git.bb
+++ b/meta-openpower/recipes-bsp/fsidbg/fsidbg_git.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "fsidbg is a tool to access remote FSI engines and perform client
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
-SRC_URI += "git://github.com/eddiejames/fsidbg.git;branch=master;protocol=https"
+SRC_URI = "git://github.com/eddiejames/fsidbg.git;branch=master;protocol=https"
SRCREV = "dfe278065c877724242dfae15a4c627fd2e3611c"
PV = "git${SRCREV}"
diff --git a/meta-openpower/recipes-bsp/pdbg/pdbg_3.6.bb b/meta-openpower/recipes-bsp/pdbg/pdbg_3.6.bb
index d0788b9933..a14b92c65b 100644
--- a/meta-openpower/recipes-bsp/pdbg/pdbg_3.6.bb
+++ b/meta-openpower/recipes-bsp/pdbg/pdbg_3.6.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "pdbg allows JTAG-like debugging of the host POWER processors"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
-SRC_URI += "git://github.com/open-power/pdbg.git;branch=master;protocol=https"
+SRC_URI = "git://github.com/open-power/pdbg.git;branch=master;protocol=https"
SRCREV = "3a21a79267bc5faa9e4bc56dc3124be610e9d475"
DEPENDS += "dtc-native"
diff --git a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
index 8f781f6354..d9cf89d4e9 100644
--- a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
+++ b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
@@ -65,7 +65,7 @@ FILES:${PN} += "${datadir}/dbus-1/system.d/org.open_power.Software.Host.Updater.
S = "${WORKDIR}/git"
-SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/openpower-pnor-code-mgmt;branch=master;protocol=https"
SRCREV = "9b837f61632ebb522a4f5cd297cbe1c477c59753"
diff --git a/meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb b/meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb
index 57256d8af1..c9443efeba 100644
--- a/meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb
+++ b/meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb
@@ -13,5 +13,5 @@ S = "${WORKDIR}/git"
SYSTEMD_SERVICE:${PN} += "pnorboot.service"
-SRC_URI += "git://github.com/shenki/aspeed-lpc-control;branch=master;protocol=https"
+SRC_URI = "git://github.com/shenki/aspeed-lpc-control;branch=master;protocol=https"
SRCREV = "af42b7ff01e71c0dd4c60214dd46ed487611f36d"
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index 59ed688679..43695548de 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -10,7 +10,7 @@ S = "${WORKDIR}/git"
inherit meson obmc-phosphor-utils pkgconfig
inherit systemd
-SRC_URI += "git://github.com/openbmc/openpower-proc-control;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/openpower-proc-control;branch=master;protocol=https"
SRCREV = "be14ec2d4350ba245538ad0330587af809fa31c2"
DEPENDS += " \
diff --git a/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb b/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb
index 8510cee01a..51bb30da5a 100644
--- a/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb
+++ b/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb
@@ -19,7 +19,7 @@ HOSTIPMI_PROVIDER_LIBRARY += "libhiomap.so"
S = "${WORKDIR}/git"
-SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-flash;branch=master;protocol=https"
+SRC_URI = "git://github.com/openbmc/openpower-host-ipmi-flash;branch=master;protocol=https"
SRCREV = "7a50cbe5a45002886e9eceb127ca5ca6f70c7efc"
EXTRA_OEMESON:append = " -Dtests=disabled"
diff --git a/meta-openpower/recipes-phosphor/logging/python3-sbe-log-parsers_git.bb b/meta-openpower/recipes-phosphor/logging/python3-sbe-log-parsers_git.bb
index 986f588c58..35d7030d3a 100644
--- a/meta-openpower/recipes-phosphor/logging/python3-sbe-log-parsers_git.bb
+++ b/meta-openpower/recipes-phosphor/logging/python3-sbe-log-parsers_git.bb
@@ -9,7 +9,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE_PROLOG;md5=d8e5f403c98fd80dcea90b9cc8cd083c"
S = "${WORKDIR}/git"
-SRC_URI += "git://git@github.com/open-power/sbe;branch="master-p10";protocol=ssh;protocol=https"
+SRC_URI = "git://git@github.com/open-power/sbe;branch="master-p10";protocol=ssh;protocol=https"
SRCREV = "f8ee8cfad2cf2a53e78789633ddffc192f5a197e"
inherit setuptools3