summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/fans/files
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2016-09-06 19:22:28 +0300
committerPatrick Williams <patrick@stwcx.xyz>2016-09-12 21:45:18 +0300
commitdbb9856f262618b8039890b5f7f9a95e68e6c312 (patch)
treeda708793f8104e01bf1b98ad12cc582240754dae /meta-phosphor/common/recipes-phosphor/fans/files
parent194b590eb913cc8463c2c7774865d6bc8b07aa17 (diff)
downloadopenbmc-dbb9856f262618b8039890b5f7f9a95e68e6c312.tar.xz
Drop obmc-phosphor- prefix from recipe collections
Given that these are already in the recipes-phosphor directory this seemed redundant. Change-Id: I48a1ab79e0eda88fc5e6af88f198ca3941e829b8 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/fans/files')
-rw-r--r--meta-phosphor/common/recipes-phosphor/fans/files/Makefile15
-rw-r--r--meta-phosphor/common/recipes-phosphor/fans/files/obmc-phosphor-fand.c29
-rw-r--r--meta-phosphor/common/recipes-phosphor/fans/files/obmc-phosphor-fand.service9
3 files changed, 53 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/fans/files/Makefile b/meta-phosphor/common/recipes-phosphor/fans/files/Makefile
new file mode 100644
index 0000000000..10e3fa2ae2
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/fans/files/Makefile
@@ -0,0 +1,15 @@
+EXE = obmc-phosphor-fand
+OBJS = $(EXE).o
+DEPPKGS = gio-unix-2.0 glib-2.0
+CC ?= $(CROSS_COMPILE)gcc
+INCLUDES += $(shell pkg-config --cflags $(DEPPKGS))
+LIBS += $(shell pkg-config --libs $(DEPPKGS))
+
+%.o : %.c
+ $(CC) -c $^ $(CFLAGS) $(INCLUDES) -o $@
+$(EXE): $(OBJS)
+ $(CC) $^ $(LDFLAGS) $(LDFLAGS) -o $@
+clean:
+ rm -f $(OBJS) $(EXE) *.o *.d
+distclean: clean
+ rm -f *.c~ *.h~ *.sh~ Makefile~ config.mk~
diff --git a/meta-phosphor/common/recipes-phosphor/fans/files/obmc-phosphor-fand.c b/meta-phosphor/common/recipes-phosphor/fans/files/obmc-phosphor-fand.c
new file mode 100644
index 0000000000..558ba10bcb
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/fans/files/obmc-phosphor-fand.c
@@ -0,0 +1,29 @@
+/* Contributors Listed Below - COPYRIGHT 2015 */
+/* [+] International Business Machines Corp. */
+/* */
+/* */
+/* Licensed under the Apache License, Version 2.0 (the "License"); */
+/* you may not use this file except in compliance with the License. */
+/* You may obtain a copy of the License at */
+/* */
+/* http://www.apache.org/licenses/LICENSE-2.0 */
+/* */
+/* Unless required by applicable law or agreed to in writing, software */
+/* distributed under the License is distributed on an "AS IS" BASIS, */
+/* WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or */
+/* implied. See the License for the specific language governing */
+/* permissions and limitations under the License. */
+
+#include <stdio.h>
+#include <stdlib.h>
+#include <gio/gio.h>
+
+int main(int argc, char *argv[])
+{
+ printf("obmc-phosphor-fand starting...\n");
+
+ while(1)
+ sleep(5);
+
+ exit(EXIT_SUCCESS);
+}
diff --git a/meta-phosphor/common/recipes-phosphor/fans/files/obmc-phosphor-fand.service b/meta-phosphor/common/recipes-phosphor/fans/files/obmc-phosphor-fand.service
new file mode 100644
index 0000000000..6698e120d4
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/fans/files/obmc-phosphor-fand.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Phosphor OpenBMC fan management daemon
+
+[Service]
+Restart=always
+ExecStart=/usr/sbin/obmc-phosphor-fand
+
+[Install]
+WantedBy=multi-user.target