summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/inventory/obmc-inventory.bb
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2017-12-14 22:31:55 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-01-30 23:37:44 +0300
commit0a8ea6354dd6b906f310316315fc49ace110a1ea (patch)
tree208ebd0de7c036c3b1d8b5cfe5037e27f4b60eaa /meta-phosphor/common/recipes-phosphor/inventory/obmc-inventory.bb
parent95eaf4978f6f92a848ba53accf02dcb52cee29b6 (diff)
downloadopenbmc-0a8ea6354dd6b906f310316315fc49ace110a1ea.tar.xz
Use variables for MRW XML filename and path
Create an mrw-xml bbclass that has variables for the MRW XML filename and path to it. Then, changes all users of the MRW XML to inherit that class and use those variables. The filename will default to ${MACHINE}.xml if it hasn't already been set to something else, such as in a .conf file. This is done so that the file can be something other than ${MACHINE}.xml. Change-Id: Ia7021e5a5d5e7946829e58688250aa64250cb00e Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/inventory/obmc-inventory.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/inventory/obmc-inventory.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/inventory/obmc-inventory.bb b/meta-phosphor/common/recipes-phosphor/inventory/obmc-inventory.bb
index baab633c43..db3a5b404c 100644
--- a/meta-phosphor/common/recipes-phosphor/inventory/obmc-inventory.bb
+++ b/meta-phosphor/common/recipes-phosphor/inventory/obmc-inventory.bb
@@ -2,6 +2,8 @@ SUMMARY = "Phosphor Inventory Generation"
DESCRIPTION = "Generates inventory data from the machine readable workbook"
PR = "r1"
+inherit mrw-xml
+
S = "${WORKDIR}/git"
PROVIDES += "virtual/obmc-inventory-data"
@@ -20,7 +22,7 @@ FILES_${PN} += "${datadir}/inventory"
do_compile() {
${STAGING_BINDIR_NATIVE}/perl-native/perl ${S}/inventory.pl \
- -x ${STAGING_DATADIR_NATIVE}/obmc-mrw/${MACHINE}.xml -o inventory.json
+ -x ${STAGING_DIR_NATIVE}${mrw_datadir}/${MRW_XML} -o inventory.json
}
do_install() {