summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-read-not-sent-by-host-inventory-native.bb
diff options
context:
space:
mode:
authorNagaraju Goruganti <ngorugan@in.ibm.com>2018-04-01 15:56:47 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-05-10 17:18:42 +0300
commit0a01e9f93b7e3528d9c5af00ac4d1b989c8b2033 (patch)
tree3f351c363200af71de6ec2d76b9a4f10488617f2 /meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-read-not-sent-by-host-inventory-native.bb
parent7929db0e23984f81491c515875d64bef9d908475 (diff)
downloadopenbmc-0a01e9f93b7e3528d9c5af00ac4d1b989c8b2033.tar.xz
Providing infra for FRUs which are accessible through host but host is
not sending the details for those FRUs - This commit adds a hand written YAML file that specifies IPMI FRU information. It is for special case where FRU info is not coming as a write-fru, it coming as a write-sensor from host because host doesn't have the required i2c access to read the GPU FRU data. - The YAML in this commit is mostly empty, and system specific overrides are supposed to add appropriate content. Partially Resolves openbmc/openbmc#3039 Change-Id: I20b43d1bb4c472dc590d254b72340fb19c52b811 Signed-off-by: Nagaraju Goruganti <ngorugan@in.ibm.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-read-not-sent-by-host-inventory-native.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-read-not-sent-by-host-inventory-native.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-read-not-sent-by-host-inventory-native.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-read-not-sent-by-host-inventory-native.bb
new file mode 100644
index 0000000000..029e6a3b02
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-fru-read-not-sent-by-host-inventory-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "The inventory map of frus not sent by host for phosphor-ipmi-host"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-ipmi-host
+
+SRC_URI += "file://fru-config-not-sent-by-host.yaml"
+
+S = "${WORKDIR}"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-read-not-sent-by-host-inventory"
+
+do_install_append() {
+ DEST=${D}${config_datadir}
+ install -d ${DEST}
+ install fru-config-not-sent-by-host.yaml ${DEST}/fru-config-not-sent-by-host.yaml
+}
+