summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-01-27 06:11:36 +0300
committerAndrew Geissler <geissonator@yahoo.com>2018-02-08 21:16:01 +0300
commit01e6b17936d00bcb0d3547873c557732abff1b80 (patch)
tree8a8c1fcd48282d3dad78d67d2ce20d97f6e83e2f /meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
parenteff3d02a180ef60102f1f25d765b2ddf72831be3 (diff)
downloadopenbmc-01e6b17936d00bcb0d3547873c557732abff1b80.tar.xz
ipmi: Refactor whitelist generation
The current dual-use of packagegroup-ipmid-providers as a dependency insertion point for both native (whitelists) and runtime (provider libs) doesn't work under Yocto 2.3. Move the ipmi provider configuration from recipe scope to the global configuration scope so we can continue to avoid dually maintaining whitelist and provider lists _and_ build under Yocto 2.3. Also rename OBMC_IPMID_PROVIDERS with the more conventional VIRTUAL-RUNTIME_phosphor-ipmi-providers. Change-Id: I1acce0b08047cba2312f60542942cccbcff66aec Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
index fe32be20de..180d70dbb7 100644
--- a/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
+++ b/meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-host.bb
@@ -12,10 +12,18 @@ inherit obmc-phosphor-systemd
inherit phosphor-ipmi-host
inherit pythonnative
+def ipmi_whitelists(d):
+ whitelists = d.getVar(
+ 'VIRTUAL-RUNTIME_phosphor-ipmi-providers', True) or ''
+ whitelists = whitelists.split()
+ whitelists = [ '{}-whitelist-native'.format(x) for x in whitelists ]
+ return ' '.join(whitelists)
+
+
DEPENDS += "autoconf-archive-native"
DEPENDS += "nlohmann-json"
DEPENDS += "obmc-targets"
-DEPENDS += "packagegroup-obmc-ipmid-providers"
+DEPENDS += "${@ipmi_whitelists(d)}"
DEPENDS += "phosphor-dbus-interfaces"
DEPENDS += "phosphor-logging"
DEPENDS += "phosphor-mapper"