summaryrefslogtreecommitdiff
path: root/meta-phosphor/common
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2016-06-09 05:27:31 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2016-06-13 19:31:32 +0300
commit10c2f855e927bcfdaedbf93681f2734792f0675e (patch)
treeeb1d42e158106f729df29c7bed51c4697ebdd112 /meta-phosphor/common
parente36358c598e688e308b43299e686fc8fa057cf84 (diff)
downloadopenbmc-10c2f855e927bcfdaedbf93681f2734792f0675e.tar.xz
Turn on socket activation for rest-dbus
Defer starting of rest-dbus until a client connects. Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common')
-rw-r--r--meta-phosphor/common/recipes-phosphor/rest-dbus/files/rest-dbus.service3
-rw-r--r--meta-phosphor/common/recipes-phosphor/rest-dbus/files/rest-dbus.socket8
-rw-r--r--meta-phosphor/common/recipes-phosphor/rest-dbus/rest-dbus.bb5
3 files changed, 11 insertions, 5 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/rest-dbus/files/rest-dbus.service b/meta-phosphor/common/recipes-phosphor/rest-dbus/files/rest-dbus.service
index 79a848a43e..5ad582f4b0 100644
--- a/meta-phosphor/common/recipes-phosphor/rest-dbus/files/rest-dbus.service
+++ b/meta-phosphor/common/recipes-phosphor/rest-dbus/files/rest-dbus.service
@@ -4,6 +4,3 @@ Description=DBUS introspecting REST server.
[Service]
Restart=always
ExecStart=/usr/sbin/rest-dbus
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-phosphor/common/recipes-phosphor/rest-dbus/files/rest-dbus.socket b/meta-phosphor/common/recipes-phosphor/rest-dbus/files/rest-dbus.socket
new file mode 100644
index 0000000000..89f99b8c34
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/rest-dbus/files/rest-dbus.socket
@@ -0,0 +1,8 @@
+[Unit]
+Description=DBUS introspecting REST server socket.
+
+[Socket]
+ListenStream=3000
+
+[Install]
+WantedBy=sockets.target
diff --git a/meta-phosphor/common/recipes-phosphor/rest-dbus/rest-dbus.bb b/meta-phosphor/common/recipes-phosphor/rest-dbus/rest-dbus.bb
index 7f990aaa3c..afee21c5e7 100644
--- a/meta-phosphor/common/recipes-phosphor/rest-dbus/rest-dbus.bb
+++ b/meta-phosphor/common/recipes-phosphor/rest-dbus/rest-dbus.bb
@@ -16,11 +16,12 @@ RDEPENDS_${PN} += " \
pyphosphor \
"
+SYSTEMD_SERVICE_${PN} += "rest-dbus.service rest-dbus.socket"
+
SRC_URI += " \
git://github.com/openbmc/rest-dbus.git \
- file://rest-dbus.service \
"
-SRCREV = "64077101d9f2b6e51c897db82ffc0a399a34d15b"
+SRCREV = "5a65d2f605494d5c308171ba4fd1ab08d7b3a91d"
S = "${WORKDIR}/git"