summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-core
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2024-01-23 00:30:51 +0300
committerAdriana Kobylak <anoo@us.ibm.com>2024-02-20 22:23:07 +0300
commitb758ca406e1f4955f222bd11d145ad96160a29d2 (patch)
tree93d0c3c581ee62d129482ca40490254fb6856672 /meta-phosphor/recipes-core
parent0e1c5bb68e346cf38ae6b61b951a8fa6944efd62 (diff)
downloadopenbmc-b758ca406e1f4955f222bd11d145ad96160a29d2.tar.xz
dropbear: Copy localoptions.h to build directory
Per the dropbear documentation, the localoptions.h file needs to be copied to its build directory to take effect. This file can later be renamed to src/distrooptions.h once the following dropbear change is merged: https://github.com/mkj/dropbear/pull/274 Tested: Before change: $ ssh -vv p10bmc ... debug2: MACs ctos: hmac-sha1,hmac-sha2-256 debug2: MACs stoc: hmac-sha1,hmac-sha2-256 After change: $ ssh -vv p10bmc ... debug2: MACs ctos: hmac-sha1,hmac-sha2-256,hmac-sha2-512 debug2: MACs stoc: hmac-sha1,hmac-sha2-256,hmac-sha2-512 Change-Id: I1a4b108d1a87831f4623c7e3e1e2beb0b8655441 Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Diffstat (limited to 'meta-phosphor/recipes-core')
-rw-r--r--meta-phosphor/recipes-core/dropbear/dropbear_%.bbappend4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-core/dropbear/dropbear_%.bbappend b/meta-phosphor/recipes-core/dropbear/dropbear_%.bbappend
index 6448fbfdb2..cc7e56c451 100644
--- a/meta-phosphor/recipes-core/dropbear/dropbear_%.bbappend
+++ b/meta-phosphor/recipes-core/dropbear/dropbear_%.bbappend
@@ -10,6 +10,10 @@ SRC_URI += "file://dropbearkey.service \
file://migrate-key-location \
"
+do_configure:append() {
+ install -m 0644 ${WORKDIR}/localoptions.h ${B}
+}
+
# pull in OpenSSH's /usr/libexec/sftp-server so we don't have to rely
# on the crufty old scp protocol for file transfer
RDEPENDS:${PN} += "openssh-sftp-server"