summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-devtools/python/python3_%.bbappend
diff options
context:
space:
mode:
authorEd Tanous <edtanous@google.com>2022-09-19 19:13:20 +0300
committerPatrick Williams <patrick@stwcx.xyz>2022-09-20 17:02:39 +0300
commit9936f86df6fc55be042cec5eb15f6e19a9e7c890 (patch)
tree251861f6bba6451ddfe328558097f6abf438d8d6 /meta-phosphor/recipes-devtools/python/python3_%.bbappend
parentbb8f0657781d78264d08d324853f94bd1abc8efa (diff)
downloadopenbmc-9936f86df6fc55be042cec5eb15f6e19a9e7c890.tar.xz
Run oe-stylize on our files
In all of our recipes, we should be following yoctos lead on formatting, order, and other things, for consistency in our meta layers. This commit runs oe-stylize.py on all of our files. The types of changes being made can be seen in the commit, but amount to: 1. Setting an explicit key ordering 2. Sectioning the files appropriately 3. Applying rules checking to our files At some point in the near future, we would turn this on as part of repotest, but some minor changes need to be upstreamed to meta-oe (WIP) to make that happen. Looking for input on whether this is something we'd like to do, and whether the diffs below look reasonable to folks. Signed-off-by: Ed Tanous <edtanous@google.com> Change-Id: I489dd21d38a9fe4f3ece89cc7a5e1d0463224abf
Diffstat (limited to 'meta-phosphor/recipes-devtools/python/python3_%.bbappend')
-rw-r--r--meta-phosphor/recipes-devtools/python/python3_%.bbappend9
1 files changed, 5 insertions, 4 deletions
diff --git a/meta-phosphor/recipes-devtools/python/python3_%.bbappend b/meta-phosphor/recipes-devtools/python/python3_%.bbappend
index a2dafcf6c3..c3de5a05f2 100644
--- a/meta-phosphor/recipes-devtools/python/python3_%.bbappend
+++ b/meta-phosphor/recipes-devtools/python/python3_%.bbappend
@@ -1,9 +1,5 @@
inherit update-alternatives
-ALTERNATIVE:${PN}-core += "python"
-ALTERNATIVE_LINK_NAME[python] = "${bindir}/python"
-ALTERNATIVE_TARGET[python] = "${bindir}/python3"
-
# python3 takes up a lot of space that most embedded systems
# do not have, so remove some un-needed files from the rootfs
do_install:append:class-target() {
@@ -11,3 +7,8 @@ do_install:append:class-target() {
# a large, compressed version of pip. Remove it to free up the space.
rm -rf ${D}${libdir}/python${PYTHON_MAJMIN}/ensurepip
}
+
+ALTERNATIVE_LINK_NAME[python] = "${bindir}/python"
+
+ALTERNATIVE:${PN}-core += "python"
+ALTERNATIVE_TARGET[python] = "${bindir}/python3"