summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-devtools/python
diff options
context:
space:
mode:
authorHarisuddin Mohamed Isa <harisuddin@gmail.com>2020-06-04 17:01:33 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-06-05 18:02:12 +0300
commite8771b153dc9d981b04c650c16072d3dfafba6c9 (patch)
tree8f725795256b8cbe8079699f99ec4dc27205f9f0 /meta-phosphor/recipes-devtools/python
parent45336c34533eb59c158ae55f38b0492c19062ec1 (diff)
downloadopenbmc-e8771b153dc9d981b04c650c16072d3dfafba6c9.tar.xz
python3: Restore .py source files
Due to PEP 3147, an earlier commit which removes .py files on rootfs broke python since .pyc files have been moved to a new directory called __pycache__ and hence no modules can be imported. This reverts those changes. (From meta-phosphor rev: 63f021136249f4f30251de79e910e54dc191a5ea) Signed-off-by: Harisuddin Mohamed Isa <harisuddin@gmail.com> Change-Id: If94ddcd0146c4312c6352db8ff1309d19f2efa96 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/recipes-devtools/python')
-rw-r--r--meta-phosphor/recipes-devtools/python/python3_%.bbappend7
1 files changed, 0 insertions, 7 deletions
diff --git a/meta-phosphor/recipes-devtools/python/python3_%.bbappend b/meta-phosphor/recipes-devtools/python/python3_%.bbappend
index 69f4e9ab02..324b28ce05 100644
--- a/meta-phosphor/recipes-devtools/python/python3_%.bbappend
+++ b/meta-phosphor/recipes-devtools/python/python3_%.bbappend
@@ -10,11 +10,4 @@ do_install_append_class-target() {
# Even though python3 is built with --without-ensurepip, it still installs
# a large, compressed version of pip. Remove it to free up the space.
rm -rf ${D}${libdir}/python${PYTHON_MAJMIN}/ensurepip
-
- # Remove all python .py files from python recipe. Only the .pyc
- # files are required.
- # The _sysconfigdata*.py files are system configuration files generated
- # during build time. It's used in the yocto packaging process so
- # it is required to remain in the image.
- find ${D}${libdir}/python${PYTHON_MAJMIN} -name \*.py ! -name _sysconfigdata*.py -exec rm {} \;
}